# CVE-2024-56373: Apache Airflow: SSTI to Code Execution in Airflow through Shared DB Information

> A DAG author can manipulate the database to trigger server-side code execution via log template history, requiring an upgrade to Airflow 3 or disabling the feature.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-airflow-2024-56373, ECHO-3a88-5f61-265a, GHSA-r837-hpv7-pc2f, MINI-39c2-jf9g-gqv2, PYSEC-2026-2355

## What is CVE-2024-56373?

CVE-2024-56373 is a high-severity code injection vulnerability in Apache Airflow, published on 24 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

DAG Author (who already has quite a lot of permissions) could manipulate database of Airflow 2 in the way to execute arbitrary code in the web-server context, which they should normally not be able to do, leading to potentially remote code execution in the context of web-server (server-side) as a result of a user viewing historical task information.

The functionality responsible for that (log template history) has been disabled by default in 2.11.1 and users should upgrade to Airflow 3 if they want to continue to use log template history. They can also manually modify historical log file names if they want to see historical logs that were generated before the last log template change.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-56373?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.11.1 |
| `apache-airflow` | PyPI | All versions | 2.11.1 |
| `apache-airflow` | PyPI | All versions | 2.11.1 |
| `airflow` | Bitnami | All versions | 2.11.1 |

Products: Apache Airflow.

## How do I fix CVE-2024-56373?

Upgrade apache-airflow to 2.11.1 or later.

## Is CVE-2024-56373 being exploited?

There is no known exploitation of CVE-2024-56373 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56373 and fix it if it is affected.

What it is: CVE-2024-56373 is a high-severity code injection vulnerability in Apache Airflow, published on 24 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-56373 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.11.1
- apache-airflow (PyPI): affected all versions; fixed in 2.11.1
- apache-airflow (PyPI): affected all versions; fixed in 2.11.1
- airflow (Bitnami): affected all versions; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56373/ (Markdown: https://insights.sbomify.com/CVE-2024-56373/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56373
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56373
- OSV: https://osv.dev/vulnerability/CVE-2024-56373

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56373/
Summaries are generated and may contain mistakes; the official description above is the record.
