CVE-2024-56374 Django has a potential denial-of-service vulnerability in IPv6 validation
Attackers can cause denial of service in Django applications by exploiting missing upper-bound limits in IPv6 validation functions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-56374?
CVE-2024-56374 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 14 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Django 5.1 before 5.1.5, 5.0 before 5.0.11, and 4.2 before 4.2.18. Lack of upper-bound limit enforcement in strings passed when performing IPv6 validation could lead to a potential denial-of-service attack. The undocumented and private functions clean_ipv6_address and is_valid_ipv6_address are vulnerable, as is the django.forms.GenericIPAddressField form field. (The django.db.models.GenericIPAddressField model field is not affected.)
Weakness: CWE-770
Which versions are affected by CVE-2024-56374?
11 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 4.2.0 | 5.1.5 |
django PyPI | From 4.2 | 4.2.18 |
django PyPI | From 4.2 | 4.2.18 |
django PyPI | From 5.0 | 5.0.11 |
django PyPI | From 5.0 | 5.0.11 |
django PyPI | From 5.1 | 5.1.5, 5.0.11, 4.2.18 |
5 more packages
django PyPI | From 5.1 | 5.1.5 |
django PyPI | From 5.1 | 5.1.5 |
Django PyPI | From 4.2 | 4.2.18 |
Django PyPI | From 5.0 | 5.0.11 |
Django PyPI | From 5.1 | 5.1.5 |
Linux distribution packages (3)
python-Django SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 4.2.11-150600.3.15.1 |
python-Django openSUSE:Leap 15.6 | All versions | 4.2.11-150600.3.15.1 |
python-Django4 openSUSE:Tumbleweed | All versions | 4.2.18-1.1 |
Products include Debian Debian Linux, Djangoproject Django.
How do I fix CVE-2024-56374?
Upgrade django to a fixed version for your release line: 5.1.5, 4.2.18 or 5.0.11.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-56374 being exploited?
There is no known exploitation of CVE-2024-56374 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-django-2024-56374, CLSA-2025-1754352704, DEBIAN-CVE-2024-56374, DLA-4030-1, GHSA-qcgg-j2x8-h9g8, OESA-2025-1069 and 6 more.