CVE-2024-56412 PhpSpreadsheet vulnerable to bypass of the XSS sanitizer using the javascript protocol and special characters

Medium 4.8 Published Updated

Attackers can bypass XSS sanitization in PhpSpreadsheet using special characters in javascript protocols, potentially executing malicious scripts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-56412?

CVE-2024-56412 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 3 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to bypass of the cross-site scripting sanitizer using the javascript protocol and special characters. An attacker can use special characters, so that the library processes the javascript protocol with special characters and generates an HTML link. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-56412?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.

PackageAffectedFixed in
phpoffice/phpspreadsheet PackagistAll versions1.29.7
phpoffice/phpspreadsheet PackagistAll versions1.29.7
phpoffice/phpspreadsheet PackagistFrom 2.0.02.1.6
phpoffice/phpspreadsheet PackagistFrom 2.0.02.1.6
phpoffice/phpspreadsheet PackagistFrom 2.2.02.3.5
phpoffice/phpspreadsheet PackagistFrom 2.2.02.3.5
4 more packages
phpoffice/phpspreadsheet PackagistFrom 3.0.03.7.0
phpoffice/phpspreadsheet PackagistFrom 3.0.03.7.0
phpoffice/phpexcel PackagistAll versions to 1.8.2None
phpoffice/phpexcel PackagistAll versions to 1.8.2None

Products include Phpoffice Phpspreadsheet.

How do I fix CVE-2024-56412?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.7, 2.1.6, 2.3.5 or 3.7.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-56412 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56412 exists.

Sources

Also known as GHSA-q9jv-mm3r-j47r.

Is CVE-2024-56412 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free