# CVE-2024-56412: PhpSpreadsheet vulnerable to bypass of the XSS sanitizer using the javascript protocol and special characters

> Attackers can bypass XSS sanitization in PhpSpreadsheet using special characters in javascript protocols, potentially executing malicious scripts.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jan 2025
- **Updated:** 3 Jan 2025
- **Also known as:** GHSA-q9jv-mm3r-j47r

## What is CVE-2024-56412?

CVE-2024-56412 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 3 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to bypass of the cross-site scripting sanitizer using the javascript protocol and special characters. An attacker can use special characters, so that the library processes the javascript protocol with special characters and generates an HTML link. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-56412?

10 open source packages ship an affected version, including phpoffice/phpspreadsheet and phpoffice/phpexcel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.7 |
| `phpoffice/phpspreadsheet` | Packagist | All versions | 1.29.7 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.6 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.0.0 | 2.1.6 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.3.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 2.2.0 | 2.3.5 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.0.0 | 3.7.0 |
| `phpoffice/phpspreadsheet` | Packagist | From 3.0.0 | 3.7.0 |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |
| `phpoffice/phpexcel` | Packagist | All versions to 1.8.2 | None |

Products: Phpoffice Phpspreadsheet.

## How do I fix CVE-2024-56412?

Upgrade phpoffice/phpspreadsheet to a fixed version for your release line: 1.29.7, 2.1.6, 2.3.5 or 3.7.0.

## Is CVE-2024-56412 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56412 exists.

## Other vulnerabilities in PHPOffice PhpSpreadsheet

- [CVE-2026-34084](https://insights.sbomify.com/CVE-2026-34084/): PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load (critical 9.2)
- [CVE-2024-45048](https://insights.sbomify.com/CVE-2024-45048/): XML External Entity Reference (XXE) in PHPSpreadsheet (high 8.8)
- [CVE-2019-12331](https://insights.sbomify.com/CVE-2019-12331/): XXE in PHPSpreadsheet due to incomplete fix for previous encoding issue (high 8.8)
- [CVE-2018-19277](https://insights.sbomify.com/CVE-2018-19277/): XXE in PHPSpreadsheet due to encoding issue (high 8.8)
- [CVE-2024-56365](https://insights.sbomify.com/CVE-2024-56365/): PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56412 and fix it if it is affected.

What it is: CVE-2024-56412 is a medium-severity cross-site scripting vulnerability in PHPOffice PhpSpreadsheet, published on 3 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56412 exists.

Affected packages and fixed versions:
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.7
- phpoffice/phpspreadsheet (Packagist): affected all versions; fixed in 1.29.7
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.6
- phpoffice/phpspreadsheet (Packagist): affected from 2.0.0; fixed in 2.1.6
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.5
- phpoffice/phpspreadsheet (Packagist): affected from 2.2.0; fixed in 2.3.5
- phpoffice/phpspreadsheet (Packagist): affected from 3.0.0; fixed in 3.7.0
- phpoffice/phpspreadsheet (Packagist): affected from 3.0.0; fixed in 3.7.0
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed
- phpoffice/phpexcel (Packagist): affected all versions up to 1.8.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56412/ (Markdown: https://insights.sbomify.com/CVE-2024-56412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56412
- OSV: https://osv.dev/vulnerability/CVE-2024-56412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56412/
Summaries are generated and may contain mistakes; the official description above is the record.
