{"answers":{"affected":"3 open source packages ship an affected version, including changedetection.io and changedetection-io.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56509 exists.","fix":"Upgrade changedetection.io to 0.48.05 or later.","what":"CVE-2024-56509 is a high-severity path traversal vulnerability in dgtlmoon changedetection.io, published on 27 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-56509 and fix it if it is affected.\n\nWhat it is: CVE-2024-56509 is a high-severity path traversal vulnerability in dgtlmoon changedetection.io, published on 27 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56509 exists.\n\nAffected packages and fixed versions:\n- changedetection.io (PyPI): affected all versions; fixed in 0.48.05\n- changedetection-io (PyPI): affected all versions; fixed in 0.48.05\n- changedetection-io (PyPI): affected all versions; fixed in 0.48.05\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56509/ (Markdown: https://insights.sbomify.com/CVE-2024-56509/index.md)","id":"CVE-2024-56509","markdown":"https://insights.sbomify.com/CVE-2024-56509/index.md","name":"CVE-2024-56509","record":{"aliases":["GHSA-j5vv-6wjg-cfr8","PYSEC-2026-1242"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Web page change detection","requires_auth":"none","summary":"Attackers can exploit improper input validation to perform local file read or path traversal attacks, accessing sensitive files on the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"changedetection.io is a free open source web page change detection, website watcher, restock monitor and notification service. Improper input validation in the application can allow attackers to perform local file read (LFR) or path traversal attacks. These vulnerabilities occur when user input is used to construct file paths without adequate sanitization or validation. For example, using file:../../../etc/passwd or file: ///etc/passwd can bypass weak validations and allow unauthorized access to sensitive files. Even though this has been addressed in previous patch, it is still insufficient. This vulnerability is fixed in 0.48.05.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"changedetection.io has Improper Input Validation Leading to LFR/Path Traversal","id":"CVE-2024-56509","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Marp Core allows XSS by improper neutralization of HTML sanitization","id":"CVE-2024-56510"},"packages":[{"ecosystem":"PyPI","fixed":["0.48.05"],"introduced":["0"],"last_affected":[],"package":"changedetection-io","purl":"pkg:pypi/changedetection-io","source":"GHSA-j5vv-6wjg-cfr8"},{"ecosystem":"PyPI","fixed":["0.48.05"],"introduced":["0"],"last_affected":[],"package":"changedetection-io","purl":"pkg:pypi/changedetection-io","source":"PYSEC-2026-1242"},{"ecosystem":"PyPI","fixed":["0.48.05"],"introduced":["0"],"last_affected":[],"package":"changedetection.io","purl":null,"source":"GHSA-j5vv-6wjg-cfr8"}],"prev":{"headline":"File Upload Vulnerability Leading to XSS in LinkAce v1.15.5","id":"CVE-2024-56508"},"products":["changedetection.io"],"published":"2024-12-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-27","vendors":["dgtlmoon"]},"summary":"Attackers can exploit improper input validation to perform local file read or path traversal attacks, accessing sensitive files on the server.","url":"https://insights.sbomify.com/CVE-2024-56509/"}