# CVE-2024-56511: DataEase has an unauthorized vulnerability

> Attackers can bypass authentication in DataEase by exploiting path traversal in whitelist matching when a custom context path is configured, leading to unauthorized access.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jan 2025
- **Updated:** 10 Jan 2025
- **Also known as:** GHSA-9f69-p73j-m73x

## What is CVE-2024-56511?

CVE-2024-56511 is a critical authentication bypass vulnerability in Dataease Dataease, published on 10 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DataEase is an open source data visualization analysis tool. Prior to 2.10.4, there is a flaw in the authentication in the io.dataease.auth.filter.TokenFilter class, which can be bypassed and cause the risk of unauthorized access. In the io.dataease.auth.filter.TokenFilter class, ”request.getRequestURI“ is used to obtain the request URL, and it is passed to the "WhitelistUtils.match" method to determine whether the URL request is an interface that does not require authentication. The "match" method filters semicolons, but this is not enough. When users set "server.servlet.context-path" when deploying products, there is still a risk of being bypassed, which can be bypassed by any whitelist prefix /geo/../context-path/. The vulnerability has been fixed in v2.10.4.

Weakness: CWE-289 (Authentication Bypass by Alternate Name)

## Which versions are affected by CVE-2024-56511?

It affects 1 product.


Products: Dataease Dataease.

## How do I fix CVE-2024-56511?

No fix has been published for CVE-2024-56511 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-56511 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56511 exists.

Public exploit code:

- DataEase < 2.10.4 - Authentication Bypass via Whitelist Path Traversal (nuclei): http/cves/2024/CVE-2024-56511.yaml

## Other vulnerabilities in Dataease Dataease

- [CVE-2024-57707](https://insights.sbomify.com/CVE-2024-57707/): Code injection in n/a (critical 9.8)
- [CVE-2024-46997](https://insights.sbomify.com/CVE-2024-46997/): DataEase's H2 datasource has a remote command execution risk (critical 9.8)
- [CVE-2023-33963](https://insights.sbomify.com/CVE-2023-33963/): DataEase data source has deserialization vulnerability (critical 9.8)
- [CVE-2023-28437](https://insights.sbomify.com/CVE-2023-28437/): SQL injection vulnerability due to the keyword blacklist for defending against SQL injection will be bypassed (critical 9.8)
- [CVE-2022-39312](https://insights.sbomify.com/CVE-2022-39312/): Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56511 and fix it if it is affected.

What it is: CVE-2024-56511 is a critical authentication bypass vulnerability in Dataease Dataease, published on 10 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56511 exists.

Affected product: Dataease Dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56511/ (Markdown: https://insights.sbomify.com/CVE-2024-56511/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56511
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56511
- OSV: https://osv.dev/vulnerability/CVE-2024-56511

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56511/
Summaries are generated and may contain mistakes; the official description above is the record.
