# CVE-2024-56512: Apache NiFi: Missing Complete Authorization for Parameter and Service References

> Authenticated users can bypass authorization checks to access unauthorized Parameter Contexts and Controller Services when creating Process Groups in Apache NiFi.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/S:P/AU:Y/R:U/V:C/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2024
- **Updated:** 30 Dec 2024
- **Also known as:** BIT-nifi-2024-56512, GHSA-mpj7-7mg7-x95j

## What is CVE-2024-56512?

CVE-2024-56512 is a low-severity missing authorization vulnerability in Apache Nifi, published on 28 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Apache NiFi 1.10.0 through 2.0.0 are missing fine-grained authorization checking for Parameter Contexts, referenced Controller Services, and referenced Parameter Providers, when creating new Process Groups.

Creating a new Process Group can include binding to a Parameter Context, but in cases where the Process Group did not reference any Parameter values, the framework did not check user authorization for the bound Parameter Context. Missing authorization for a bound Parameter Context enabled clients to download non-sensitive Parameter values after creating the Process Group.

Creating a new Process Group can also include referencing existing Controller Services or Parameter Providers. The framework did not check user authorization for referenced Controller Services or Parameter Providers, enabling clients to create Process Groups and use these components that were otherwise unauthorized.

This vulnerability is limited in scope to authenticated users authorized to create Process Groups. The scope is further limited to deployments with component-based authorization policies. Upgrading to Apache NiFi 2.1.0 is the recommended mitigation, which includes authorization checking for Parameter and Controller Service references on Process Group creation.

Weakness: CWE-862 (Missing Authorization), CWE-638 (Not Using Complete Mediation)

## Which versions are affected by CVE-2024-56512?

3 open source packages ship an affected version, including org.apache.nifi:nifi-web-api and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-web-api` | Maven | From 1.10.0 | 2.1.0 |
| `org.apache.nifi:nifi-web-api` | Maven | From 1.10.0 | 2.1.0 |
| `nifi` | Bitnami | From 1.10.0 | 2.1.0 |

Products: Apache Nifi.

## How do I fix CVE-2024-56512?

Upgrade org.apache.nifi:nifi-web-api to 2.1.0 or later.

## Is CVE-2024-56512 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56512 exists.

Public exploit code:

- A tool to exploit the CVE-2024-56512  vulnerability in Apache NiFi, which allows unauthorized access to sensitive data through improperly secured APIs. (github_poc): https://github.com/absholi7ly/CVE-2024-56512-Apache-NiFi-Exploit
- Apache NiFi - Information Disclosure (nuclei): http/cves/2024/CVE-2024-56512.yaml

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56512 and fix it if it is affected.

What it is: CVE-2024-56512 is a low-severity missing authorization vulnerability in Apache Nifi, published on 28 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56512 exists.

Affected packages and fixed versions:
- org.apache.nifi:nifi-web-api (Maven): affected from 1.10.0; fixed in 2.1.0
- org.apache.nifi:nifi-web-api (Maven): affected from 1.10.0; fixed in 2.1.0
- nifi (Bitnami): affected from 1.10.0; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56512/ (Markdown: https://insights.sbomify.com/CVE-2024-56512/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56512
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56512
- OSV: https://osv.dev/vulnerability/CVE-2024-56512

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56512/
Summaries are generated and may contain mistakes; the official description above is the record.
