# CVE-2024-56513: Karmada PULL Mode Cluster Privilege Escalation

> An attacker authenticating as karmada-agent can escalate privileges to control the entire Karmada federation and all member clusters.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2025
- **Updated:** 3 Jan 2025
- **Also known as:** GHSA-mg7w-c9x2-xh7r, GO-2025-3364

## What is CVE-2024-56513?

CVE-2024-56513 is a high-severity vulnerability in karmada-io karmada, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Karmada is a Kubernetes management system that allows users to run cloud-native applications across multiple Kubernetes clusters and clouds. Prior to version 1.12.0, the PULL mode clusters registered with the `karmadactl register` command have excessive privileges to access control plane resources. By abusing these permissions, an attacker able to authenticate as the karmada-agent to a karmada cluster would be able to obtain administrative privileges over the entire federation system including all registered member clusters. Since Karmada v1.12.0, command `karmadactl register` restricts the access permissions of pull mode member clusters to control plane resources. This way, an attacker able to authenticate as the karmada-agent cannot control other member clusters in Karmada. As a workaround, one may restrict the access permissions of pull mode member clusters to control plane resources according to Karmada Component Permissions Docs.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2024-56513?

3 open source packages ship an affected version, including github.com/karmada-io/karmada.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/karmada-io/karmada` | Go | All versions | 1.12.0 |
| `github.com/karmada-io/karmada` | Go | All versions | 1.12.0 |
| `github.com/karmada-io/karmada` | Go | All versions | 1.12.0 |

## How do I fix CVE-2024-56513?

Upgrade github.com/karmada-io/karmada to 1.12.0 or later.

## Is CVE-2024-56513 being exploited?

There is no known exploitation of CVE-2024-56513 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56513 and fix it if it is affected.

What it is: CVE-2024-56513 is a high-severity vulnerability in karmada-io karmada, published on 3 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56513 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/karmada-io/karmada (Go): affected all versions; fixed in 1.12.0
- github.com/karmada-io/karmada (Go): affected all versions; fixed in 1.12.0
- github.com/karmada-io/karmada (Go): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56513/ (Markdown: https://insights.sbomify.com/CVE-2024-56513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56513
- OSV: https://osv.dev/vulnerability/CVE-2024-56513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56513/
Summaries are generated and may contain mistakes; the official description above is the record.
