# CVE-2024-56522: TCPDF has incorrect comparison

> An attacker can bypass TCPDF tag hash verification due to insecure loose comparison, potentially compromising document integrity.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Dec 2024
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-56522, GHSA-w95c-7994-ghpr, UBUNTU-CVE-2024-56522

## What is CVE-2024-56522?

CVE-2024-56522 is a high-severity vulnerability in tecnick tcpdf, published on 27 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in TCPDF before 6.8.0. unserializeTCPDFtag uses != (aka loose comparison) and does not use a constant-time function to compare TCPDF tag hashes.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2024-56522?

2 open source packages ship an affected version, including tecnickcom/tcpdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tecnickcom/tcpdf` | Packagist | All versions | 6.8.0 |
| `tecnickcom/tcpdf` | Packagist | All versions | 6.8.0 |

Products: Tcpdf Project Tcpdf.

## How do I fix CVE-2024-56522?

Upgrade tecnickcom/tcpdf to 6.8.0 or later.

## Is CVE-2024-56522 being exploited?

There is no known exploitation of CVE-2024-56522 in the wild and no public exploit code.

## Other vulnerabilities in tecnick tcpdf

- [CVE-2024-56521](https://insights.sbomify.com/CVE-2024-56521/): TCPDF missing certificate validation (critical 9.8)
- [CVE-2024-56519](https://insights.sbomify.com/CVE-2024-56519/): TCPDF lacks SVG sanitization (high 7.5)
- [CVE-2024-56527](https://insights.sbomify.com/CVE-2024-56527/): TCPDF missing character escape on error messages (high 7.5)
- [CVE-2024-22641](https://insights.sbomify.com/CVE-2024-22641/): Denial of service in n/a (high 7.5)
- [CVE-2017-6100](https://insights.sbomify.com/CVE-2017-6100/): Server-side request forgery in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56522 and fix it if it is affected.

What it is: CVE-2024-56522 is a high-severity vulnerability in tecnick tcpdf, published on 27 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56522 in the wild and no public exploit code.

Affected packages and fixed versions:
- tecnickcom/tcpdf (Packagist): affected all versions; fixed in 6.8.0
- tecnickcom/tcpdf (Packagist): affected all versions; fixed in 6.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56522/ (Markdown: https://insights.sbomify.com/CVE-2024-56522/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56522
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56522
- OSV: https://osv.dev/vulnerability/CVE-2024-56522

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56522/
Summaries are generated and may contain mistakes; the official description above is the record.
