# CVE-2024-56526: OXID eShop May Display User Information

> Attackers can view user information via CMS pages with Smarty syntax errors in OXID eShop.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2025
- **Updated:** 14 May 2025
- **Also known as:** GHSA-qqcr-9jfc-35c4

## What is CVE-2024-56526?

CVE-2024-56526 is a high-severity vulnerability in n/a, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in OXID eShop before 7. CMS pages in combination with Smarty may display user information if a CMS page contains a Smarty syntax error.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-56526?

6 open source packages ship an affected version, including oxid-esales/oxideshop-ce, oxid-esales/oxideshop-metapackage-ce and oxid-esales/smarty-component. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oxid-esales/oxideshop-ce` | Packagist | From 6.0.0 | 6.14.4 |
| `oxid-esales/oxideshop-ce` | Packagist | From 6.0.0 | 6.14.4 |
| `oxid-esales/oxideshop-metapackage-ce` | Packagist | From 6.0.0 | 6.5.5 |
| `oxid-esales/oxideshop-metapackage-ce` | Packagist | From 6.0.0 | 6.5.5 |
| `oxid-esales/smarty-component` | Packagist | All versions | 1.0.1 |
| `oxid-esales/smarty-component` | Packagist | All versions | 1.0.1 |

Products: Oxid-Esales Eshop.

## How do I fix CVE-2024-56526?

Upgrade oxid-esales/oxideshop-ce to 6.14.4 or later.

## Is CVE-2024-56526 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56526 exists.

## Other vulnerabilities in n/a

- [CVE-2019-13026](https://insights.sbomify.com/CVE-2019-13026/): SQL injection in n/a (critical 9.8)
- [CVE-2018-20715](https://insights.sbomify.com/CVE-2018-20715/): SQL injection in n/a (critical 9.8)
- [CVE-2019-17062](https://insights.sbomify.com/CVE-2019-17062/): Auth bypass in n/a (high 8.8)
- [CVE-2018-12579](https://insights.sbomify.com/CVE-2018-12579/): Auth bypass in n/a (high 8.1)
- [CVE-2017-12415](https://insights.sbomify.com/CVE-2017-12415/): Cross-site request forgery in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56526 and fix it if it is affected.

What it is: CVE-2024-56526 is a high-severity vulnerability in n/a, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56526 exists.

Affected packages and fixed versions:
- oxid-esales/oxideshop-ce (Packagist): affected from 6.0.0; fixed in 6.14.4
- oxid-esales/oxideshop-ce (Packagist): affected from 6.0.0; fixed in 6.14.4
- oxid-esales/oxideshop-metapackage-ce (Packagist): affected from 6.0.0; fixed in 6.5.5
- oxid-esales/oxideshop-metapackage-ce (Packagist): affected from 6.0.0; fixed in 6.5.5
- oxid-esales/smarty-component (Packagist): affected all versions; fixed in 1.0.1
- oxid-esales/smarty-component (Packagist): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56526/ (Markdown: https://insights.sbomify.com/CVE-2024-56526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56526
- OSV: https://osv.dev/vulnerability/CVE-2024-56526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56526/
Summaries are generated and may contain mistakes; the official description above is the record.
