# CVE-2024-5657: CraftCMS Plugin - Two-Factor Authentication - Password Hash Disclosure

> An attacker can obtain the authenticated user's password hash by submitting a valid TOTP code in the CraftCMS Two-Factor Authentication plugin.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 3 Sep 2025
- **Also known as:** GHSA-3p4x-grpm-xw58

## What is CVE-2024-5657?

CVE-2024-5657 is a low-severity vulnerability in Born05 CraftCMS Plugin - Two-Factor Authentication, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The CraftCMS plugin Two-Factor Authentication in versions 3.3.1, 3.3.2 and 3.3.3 discloses the password hash of the currently authenticated user after submitting a valid TOTP.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-499 (Serializable Class Containing Sensitive Data)

## Which versions are affected by CVE-2024-5657?

2 open source packages ship an affected version, including born05/craft-twofactorauthentication. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `born05/craft-twofactorauthentication` | Packagist | From 3.3.1 | 3.3.4 |
| `born05/craft-twofactorauthentication` | Packagist | From 3.3.1 | 3.3.4 |

Products: Born05 Two-Factor Authentication.

## How do I fix CVE-2024-5657?

Upgrade born05/craft-twofactorauthentication to 3.3.4 or later.

## Is CVE-2024-5657 being exploited?

There is no known exploitation of CVE-2024-5657 in the wild and no public exploit code.

## Other vulnerabilities in Born05 CraftCMS Plugin - Two-Factor Authentication

- [CVE-2024-5658](https://insights.sbomify.com/CVE-2024-5658/): CraftCMS Plugin - Two-Factor Authentication - TOTP Token Stays Valid After Use (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5657 and fix it if it is affected.

What it is: CVE-2024-5657 is a low-severity vulnerability in Born05 CraftCMS Plugin - Two-Factor Authentication, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-5657 in the wild and no public exploit code.

Affected packages and fixed versions:
- born05/craft-twofactorauthentication (Packagist): affected from 3.3.1; fixed in 3.3.4
- born05/craft-twofactorauthentication (Packagist): affected from 3.3.1; fixed in 3.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5657/ (Markdown: https://insights.sbomify.com/CVE-2024-5657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5657
- OSV: https://osv.dev/vulnerability/CVE-2024-5657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5657/
Summaries are generated and may contain mistakes; the official description above is the record.
