# CVE-2024-5658: CraftCMS Plugin - Two-Factor Authentication - TOTP Token Stays Valid After Use

> Attackers can reuse TOTP tokens to bypass two-factor authentication and take over accounts in the CraftCMS Two-Factor Authentication plugin.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 3 Sep 2025
- **Also known as:** GHSA-96qm-hwhp-2rm8

## What is CVE-2024-5658?

CVE-2024-5658 is a medium-severity authentication bypass vulnerability in Born05 CraftCMS Plugin - Two-Factor Authentication, published on 6 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The CraftCMS plugin Two-Factor Authentication through 3.3.3 allows reuse of TOTP tokens multiple times within the validity period.

Weakness: CWE-287 (Improper Authentication), CWE-303 (Incorrect Implementation of Authentication Algorithm)

## Which versions are affected by CVE-2024-5658?

2 open source packages ship an affected version, including born05/craft-twofactorauthentication. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `born05/craft-twofactorauthentication` | Packagist | All versions | 3.3.4 |
| `born05/craft-twofactorauthentication` | Packagist | All versions | 3.3.4 |

Products: Born05 Two-Factor Authentication.

## How do I fix CVE-2024-5658?

Upgrade born05/craft-twofactorauthentication to 3.3.4 or later.

## Is CVE-2024-5658 being exploited?

There is no known exploitation of CVE-2024-5658 in the wild and no public exploit code.

## Other vulnerabilities in Born05 CraftCMS Plugin - Two-Factor Authentication

- [CVE-2024-5657](https://insights.sbomify.com/CVE-2024-5657/): CraftCMS Plugin - Two-Factor Authentication - Password Hash Disclosure (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5658 and fix it if it is affected.

What it is: CVE-2024-5658 is a medium-severity authentication bypass vulnerability in Born05 CraftCMS Plugin - Two-Factor Authentication, published on 6 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-5658 in the wild and no public exploit code.

Affected packages and fixed versions:
- born05/craft-twofactorauthentication (Packagist): affected all versions; fixed in 3.3.4
- born05/craft-twofactorauthentication (Packagist): affected all versions; fixed in 3.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5658/ (Markdown: https://insights.sbomify.com/CVE-2024-5658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5658
- OSV: https://osv.dev/vulnerability/CVE-2024-5658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5658/
Summaries are generated and may contain mistakes; the official description above is the record.
