# CVE-2024-56731: Gogs deletion of internal files allows remote command execution

> Unprivileged users can delete internal Git files to achieve remote command execution on the server, compromising all hosted code.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2025
- **Updated:** 25 Jun 2025
- **Also known as:** GHSA-wj44-9vcg-wjq7, GO-2025-3776

## What is CVE-2024-56731?

CVE-2024-56731 is a critical command injection vulnerability in gogs, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gogs is an open source self-hosted Git service. Prior to version 0.13.3, it's still possible to delete files under the .git directory and achieve remote command execution due to an insufficient patch for CVE-2024-39931. Unprivileged user accounts can execute arbitrary commands on the Gogs instance with the privileges of the account specified by RUN_USER in the configuration. Allowing attackers to access and alter any users' code hosted on the same instance. This issue has been patched in version 0.13.3.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2024-56731?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | 0.13.3 |
| `gogs.io/gogs` | Go | All versions | 0.13.3 |
| `gogs.io/gogs` | Go | All versions | 0.13.3 |

Products: Gogs Gogs.

## How do I fix CVE-2024-56731?

Upgrade gogs.io/gogs to 0.13.3 or later.

## Is CVE-2024-56731 being exploited?

There is no known exploitation of CVE-2024-56731 in the wild and no public exploit code.

## Other vulnerabilities in gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1986](https://insights.sbomify.com/CVE-2022-1986/): OS Command Injection in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)
- [CVE-2024-39930](https://insights.sbomify.com/CVE-2024-39930/): Duplicate Advisory: github.com/gogs/gogs affected by CVE-2024-39930 (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56731 and fix it if it is affected.

What it is: CVE-2024-56731 is a critical command injection vulnerability in gogs, published on 24 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56731 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.3
- gogs.io/gogs (Go): affected all versions; fixed in 0.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56731/ (Markdown: https://insights.sbomify.com/CVE-2024-56731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56731
- OSV: https://osv.dev/vulnerability/CVE-2024-56731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56731/
Summaries are generated and may contain mistakes; the official description above is the record.
