# CVE-2024-56734: Better Auth has an Open Redirect Vulnerability in Verify Email Endpoint

> Attackers can redirect users to malicious sites via the verify email endpoint due to missing domain validation, affecting Better Auth users.

- **Severity:** High 7.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2024
- **Updated:** 30 Dec 2024
- **Also known as:** GHSA-8jhw-6pjj-8723

## What is CVE-2024-56734?

CVE-2024-56734 is a high-severity vulnerability in better-auth, published on 30 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Better Auth is an authentication library for TypeScript. An open redirect vulnerability has been identified in the verify email endpoint of all versions of Better Auth prior to v1.1.6, potentially allowing attackers to redirect users to malicious websites. This issue affects users relying on email verification links generated by the library. The verify email callback endpoint accepts a `callbackURL` parameter. Unlike other verification methods, email verification only uses JWT to verify and redirect without proper validation of the target domain. The origin checker is bypassed in this scenario because it only checks for `POST` requests. An attacker can manipulate this parameter to redirect users to arbitrary URLs controlled by the attacker. Version 1.1.6 contains a patch for the issue.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2024-56734?

2 open source packages ship an affected version, including better-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `better-auth` | npm | All versions | 1.1.6 |
| `better-auth` | npm | All versions | 1.1.6 |

Products: Better-Auth Better Auth.

## How do I fix CVE-2024-56734?

Upgrade better-auth to 1.1.6 or later.

## Is CVE-2024-56734 being exploited?

There is no known exploitation of CVE-2024-56734 in the wild and no public exploit code.

## Other vulnerabilities in better-auth

- [CVE-2026-53512](https://insights.sbomify.com/CVE-2026-53512/): Better Auth: OAuth refresh-token replay via missing client authentication on oidc-provider and mcp plugins (critical 9.1)
- [CVE-2026-53516](https://insights.sbomify.com/CVE-2026-53516/): Better Auth: Account takeover via OAuth auto-link to unverified pre-registered email (high 8.3)
- [CVE-2026-53514](https://insights.sbomify.com/CVE-2026-53514/): Better Auth: Unauthorized invitation acceptance via unverified email match in organization plugin (high 7.7)
- [CVE-2026-45337](https://insights.sbomify.com/CVE-2026-45337/): Better Auth: Device authorization approve and deny accept any authenticated session while the user code is pending (high 7.6)
- [CVE-2025-27143](https://insights.sbomify.com/CVE-2025-27143/): Beter Auth has an Open Redirect via Scheme-Less Callback Parameter (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56734 and fix it if it is affected.

What it is: CVE-2024-56734 is a high-severity vulnerability in better-auth, published on 30 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56734 in the wild and no public exploit code.

Affected packages and fixed versions:
- better-auth (npm): affected all versions; fixed in 1.1.6
- better-auth (npm): affected all versions; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56734/ (Markdown: https://insights.sbomify.com/CVE-2024-56734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56734
- OSV: https://osv.dev/vulnerability/CVE-2024-56734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56734/
Summaries are generated and may contain mistakes; the official description above is the record.
