# CVE-2024-56799: Simofa Allows Unauthenticated Access to API Routes

> Attackers can access protected API routes without authentication due to a design flaw in Simofa, potentially exposing or modifying data.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Dec 2024
- **Updated:** 30 Dec 2024
- **Also known as:** GHSA-83qw-5qq5-v7pq

## What is CVE-2024-56799?

CVE-2024-56799 is a critical missing authorization vulnerability in TrueWinter simofa, published on 30 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Simofa is a tool to help automate static website building and deployment. Prior to version 0.2.7, due to a design mistake in the RouteLoader class, some API routes may be publicly accessible when they should require authentication. This vulnerability has been patched in v0.2.7.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2024-56799?


## How do I fix CVE-2024-56799?

No fix has been published for CVE-2024-56799 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-56799 being exploited?

There is no known exploitation of CVE-2024-56799 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56799 and fix it if it is affected.

What it is: CVE-2024-56799 is a critical missing authorization vulnerability in TrueWinter simofa, published on 30 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-56799 in the wild and no public exploit code.

Affected product: TrueWinter simofa. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56799/ (Markdown: https://insights.sbomify.com/CVE-2024-56799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56799
- OSV: https://osv.dev/vulnerability/CVE-2024-56799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56799/
Summaries are generated and may contain mistakes; the official description above is the record.
