{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-56800 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-56800 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-56800 is a high-severity server-side request forgery vulnerability in mendableai firecrawl, published on 30 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-56800 and fix it if it is affected.\n\nWhat it is: CVE-2024-56800 is a high-severity server-side request forgery vulnerability in mendableai firecrawl, published on 30 Dec 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-56800 in the wild and no public exploit code.\n\nAffected product: mendableai firecrawl. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-56800/ (Markdown: https://insights.sbomify.com/CVE-2024-56800/index.md)","id":"CVE-2024-56800","markdown":"https://insights.sbomify.com/CVE-2024-56800/index.md","name":"CVE-2024-56800","record":{"aliases":[],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Web scraping service","requires_auth":"low_privilege","summary":"Attackers can exploit a malicious scrape target to redirect requests to local IPs, allowing exfiltration of local network resources via the API.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Firecrawl is a web scraper that allows users to extract the content of a webpage for a large language model. Versions prior to 1.1.1 contain a server-side request forgery (SSRF) vulnerability. The scraping engine could be exploited by crafting a malicious site that redirects to a local IP address. This allowed exfiltration of local network resources through the API. The cloud service was patched on December 27th, 2024, and the maintainers have checked that no user data was exposed by this vulnerability. Scraping engines used in the open sourced version of Firecrawl were patched on December 29th, 2024, except for the playwright services which the maintainers have determined to be un-patchable. All users of open-source software (OSS) Firecrawl should upgrade to v1.1.1. As a workaround, OSS Firecrawl users should supply the playwright services with a secure proxy. A proxy can be specified through the `PROXY_SERVER` env in the environment variables. Please refer to the documentation for instructions. Ensure that the proxy server one is using is setup to block all traffic going to link-local IP addresses.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2025-10-23","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-10-23T23:36:16Z","kind":"github_poc","ref":"https://github.com/cyhe50/cve-2024-56800-poc","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":false,"headline":"Firecrawl has SSRF Vulnerability via malicious scrape target","id":"CVE-2024-56800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Tasklists has Blind SQL Injection in /ajax/reorder.php","id":"CVE-2024-56801"},"packages":[],"prev":{"headline":"Simofa Allows Unauthenticated Access to API Routes","id":"CVE-2024-56799"},"products":["firecrawl"],"published":"2024-12-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-30","vendors":["mendableai"]},"summary":"Attackers can exploit a malicious scrape target to redirect requests to local IPs, allowing exfiltration of local network resources via the API.","url":"https://insights.sbomify.com/CVE-2024-56800/"}