{"answers":{"affected":"2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-5685 in the wild and no public exploit code.","fix":"Upgrade snipe/snipe-it to 6.4.2 or later.","what":"CVE-2024-5685 is a high-severity missing authorization vulnerability in Snipeitapp Snipe-It, published on 14 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-5685 and fix it if it is affected.\n\nWhat it is: CVE-2024-5685 is a high-severity missing authorization vulnerability in Snipeitapp Snipe-It, published on 14 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-5685 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snipe/snipe-it (Packagist): affected all versions; fixed in 6.4.2\n- snipe/snipe-it (Packagist): affected all versions; fixed in 6.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-5685/ (Markdown: https://insights.sbomify.com/CVE-2024-5685/index.md)","id":"CVE-2024-5685","markdown":"https://insights.sbomify.com/CVE-2024-5685/index.md","name":"CVE-2024-5685","record":{"aliases":["GHSA-544r-fc65-v832"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Asset Management System","requires_auth":"low_privilege","summary":"Users with specific edit permissions can improperly modify group memberships to escalate privileges via API calls.","user_interaction":"required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Checkmarx","cpe":[{"product":"snipe-it","vendor":"snipeitapp"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Users with \"User:edit\" and \"Self:api\" permissions can promote or demote themselves or other users by performing changes to the group's memberships via API call.This issue affects snipe-it: from v4.6.17 through v6.4.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Broken Function Level Authorization (BFLA) in snipe/snipe-it","id":"CVE-2024-5685","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"snipeitapp:snipe-it","products":["snipeitapp:snipe-it"],"type":"missing_authorization","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site scripting in WPZOOM Addons for Elementor – Starter Templates \u0026 Widgets","id":"CVE-2024-5686"},"packages":[{"ecosystem":"Packagist","fixed":["6.4.2"],"introduced":["0"],"last_affected":[],"package":"snipe/snipe-it","purl":null,"source":"GHSA-544r-fc65-v832"},{"ecosystem":"Packagist","fixed":["6.4.2"],"introduced":["0"],"last_affected":[],"package":"snipe/snipe-it","purl":"pkg:composer/snipe/snipe-it","source":"GHSA-544r-fc65-v832"}],"prev":{"headline":"ID Charger Connect \u0026 Pro - JWT-Null-Algorithm","id":"CVE-2024-5684"},"products":["snipe-it"],"published":"2024-06-14","related":[{"cvss_score":9.9,"headline":"File upload in n/a","id":"CVE-2025-63601","kev_date_added":null,"published":"2025-11-05"},{"cvss_score":9.8,"headline":"Snipe-IT has insecure permissions in file uploads","id":"CVE-2026-37709","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":9.3,"headline":"Snipe-IT before 8.7.0 CSS Injection via Custom CSS","id":"CVE-2026-86738","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback","id":"CVE-2026-116199","kev_date_added":null,"published":"2026-10-25"},{"cvss_score":9.1,"headline":"Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it","id":"CVE-2022-1380","kev_date_added":null,"published":"2022-04-16"},{"cvss_score":9,"headline":"Stored Cross Site Scripting vulnerability in the checked_out_to parameter in snipe/snipe-it","id":"CVE-2022-1445","kev_date_added":null,"published":"2022-04-24"},{"cvss_score":8.8,"headline":"Snipe-IT - Host Header Injection","id":"CVE-2022-23064","kev_date_added":null,"published":"2022-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["snipe"]},"summary":"Users with specific edit permissions can improperly modify group memberships to escalate privileges via API calls.","url":"https://insights.sbomify.com/CVE-2024-5685/"}