CVE-2024-56923 Cross site scripting in Silverpeas Core
Remote attackers can inject malicious JavaScript into subscription names, leading to session hijacking or data theft when admins view the content.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-56923?
CVE-2024-56923 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Stored Cross-Site Scripting (XSS) Vulnerability in the Categorization Option of My Subscriptions Functionality in Silverpeas Core 6.3.1 <= 6.4.1 allows a remote attacker to execute arbitrary JavaScript code. This is achieved by injecting a malicious payload into the Name field of a subscription. The attack can lead to session hijacking, data theft, or unauthorized actions when an admin user views the affected subscription.
Weakness: CWE-79
Which versions are affected by CVE-2024-56923?
2 open source packages ship an affected version, including org.silverpeas.core:silverpeas-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.silverpeas.core:silverpeas-core Maven | From 6.3.1 | 6.4.2 |
org.silverpeas.core:silverpeas-core Maven | From 6.3.1 | 6.4.2 |
Products include Silverpeas Silverpeas.
How do I fix CVE-2024-56923?
Upgrade org.silverpeas.core:silverpeas-core to 6.4.2 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-56923 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56923 exists.
Other vulnerabilities in n/a
Sources
Also known as GHSA-788m-27g4-cf86.