# CVE-2024-56923: Cross site scripting in Silverpeas Core

> Remote attackers can inject malicious JavaScript into subscription names, leading to session hijacking or data theft when admins view the content.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2025
- **Updated:** 28 Jan 2025
- **Also known as:** GHSA-788m-27g4-cf86

## What is CVE-2024-56923?

CVE-2024-56923 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Stored Cross-Site Scripting (XSS) Vulnerability in the Categorization Option of My Subscriptions Functionality in Silverpeas Core 6.3.1 <= 6.4.1 allows a remote attacker to execute arbitrary JavaScript code. This is achieved by injecting a malicious payload into the Name field of a subscription. The attack can lead to session hijacking, data theft, or unauthorized actions when an admin user views the affected subscription.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-56923?

2 open source packages ship an affected version, including org.silverpeas.core:silverpeas-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.silverpeas.core:silverpeas-core` | Maven | From 6.3.1 | 6.4.2 |
| `org.silverpeas.core:silverpeas-core` | Maven | From 6.3.1 | 6.4.2 |

Products: Silverpeas Silverpeas.

## How do I fix CVE-2024-56923?

Upgrade org.silverpeas.core:silverpeas-core to 6.4.2 or later.

## Is CVE-2024-56923 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56923 exists.

## Other vulnerabilities in n/a

- [CVE-2018-19586](https://insights.sbomify.com/CVE-2018-19586/): Path traversal in n/a (critical 9.9)
- [CVE-2024-42850](https://insights.sbomify.com/CVE-2024-42850/): Silverpeas vulnerable to password complexity rule bypass (critical 9.8)
- [CVE-2024-36042](https://insights.sbomify.com/CVE-2024-36042/): Silverpeas authentication bypass (critical 9.8)
- [CVE-2023-47322](https://insights.sbomify.com/CVE-2023-47322/): Cross Site Request Forgery in Silverpeas (high 8.8)
- [CVE-2023-47326](https://insights.sbomify.com/CVE-2023-47326/): Cross Site Request Forgery in Silverpeas (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-56923 and fix it if it is affected.

What it is: CVE-2024-56923 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-56923 exists.

Affected packages and fixed versions:
- org.silverpeas.core:silverpeas-core (Maven): affected from 6.3.1; fixed in 6.4.2
- org.silverpeas.core:silverpeas-core (Maven): affected from 6.3.1; fixed in 6.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-56923/ (Markdown: https://insights.sbomify.com/CVE-2024-56923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-56923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-56923
- OSV: https://osv.dev/vulnerability/CVE-2024-56923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-56923/
Summaries are generated and may contain mistakes; the official description above is the record.
