{"answers":{"affected":"2 open source packages ship an affected version, including nodebb. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57041 exists.","fix":"Upgrade nodebb to 3.11.1 or later.","what":"CVE-2024-57041 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-57041 and fix it if it is affected.\n\nWhat it is: CVE-2024-57041 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57041 exists.\n\nAffected packages and fixed versions:\n- nodebb (npm): affected all versions; fixed in 3.11.1\n- nodebb (npm): affected all versions; fixed in 3.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-57041/ (Markdown: https://insights.sbomify.com/CVE-2024-57041/index.md)","id":"CVE-2024-57041","markdown":"https://insights.sbomify.com/CVE-2024-57041/index.md","name":"CVE-2024-57041","record":{"aliases":["GHSA-vqr3-vrrg-f3jh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"NodeBB forum software","requires_auth":"low_privilege","summary":"Remote attackers can inject persistent scripts into user profiles, potentially executing code in other users' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"nodebb","vendor":"nodebb"}],"cvss":{"score":4.6,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A persistent cross-site scripting (XSS) vulnerability in NodeBB v3.11.0 allows remote attackers to store arbitrary code in the 'about me' section of their profile.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"NodeBB Cross-site scripting (XSS) vulnerability","id":"CVE-2024-57041","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Auth bypass in n/a","id":"CVE-2024-57045"},"packages":[{"ecosystem":"npm","fixed":["3.11.1"],"introduced":["0"],"last_affected":[],"package":"nodebb","purl":null,"source":"GHSA-vqr3-vrrg-f3jh"},{"ecosystem":"npm","fixed":["3.11.1"],"introduced":["0"],"last_affected":[],"package":"nodebb","purl":"pkg:npm/nodebb","source":"GHSA-vqr3-vrrg-f3jh"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2024-57040"},"products":["n/a"],"published":"2025-01-24","related":[{"cvss_score":10,"headline":"NodeBB vulnerable to path traversal and code execution via prototype vulnerability","id":"CVE-2023-26045","kev_date_added":null,"published":"2023-07-24"},{"cvss_score":9.9,"headline":"Account takeover in NodeBB","id":"CVE-2020-15149","kev_date_added":null,"published":"2020-08-19"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2023-43187","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":9.8,"headline":"API token verification can be bypassed","id":"CVE-2021-43786","kev_date_added":null,"published":"2021-11-29"},{"cvss_score":9.4,"headline":"Account takeover via prototype vulnerability","id":"CVE-2022-46164","kev_date_added":null,"published":"2022-12-05"},{"cvss_score":9,"headline":"Account takeover via cryptographically weak PRNG in NodeBB Forum","id":"CVE-2022-36045","kev_date_added":null,"published":"2022-08-31"},{"cvss_score":9,"headline":"XSS via prototype pollution","id":"CVE-2021-43787","kev_date_added":null,"published":"2021-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-05","vendors":["n/a"]},"summary":"Remote attackers can inject persistent scripts into user profiles, potentially executing code in other users' browsers.","url":"https://insights.sbomify.com/CVE-2024-57041/"}