# CVE-2024-57041: NodeBB Cross-site scripting (XSS) vulnerability

> Remote attackers can inject persistent scripts into user profiles, potentially executing code in other users' browsers.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2025
- **Updated:** 5 Jul 2026
- **Also known as:** GHSA-vqr3-vrrg-f3jh

## What is CVE-2024-57041?

CVE-2024-57041 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A persistent cross-site scripting (XSS) vulnerability in NodeBB v3.11.0 allows remote attackers to store arbitrary code in the 'about me' section of their profile.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-57041?

2 open source packages ship an affected version, including nodebb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebb` | npm | All versions | 3.11.1 |
| `nodebb` | npm | All versions | 3.11.1 |

Products: Nodebb Nodebb.

## How do I fix CVE-2024-57041?

Upgrade nodebb to 3.11.1 or later.

## Is CVE-2024-57041 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57041 exists.

## Other vulnerabilities in n/a

- [CVE-2023-26045](https://insights.sbomify.com/CVE-2023-26045/): NodeBB vulnerable to path traversal and code execution via prototype vulnerability (critical 10.0)
- [CVE-2020-15149](https://insights.sbomify.com/CVE-2020-15149/): Account takeover in NodeBB (critical 9.9)
- [CVE-2023-43187](https://insights.sbomify.com/CVE-2023-43187/): Code injection in n/a (critical 9.8)
- [CVE-2021-43786](https://insights.sbomify.com/CVE-2021-43786/): API token verification can be bypassed (critical 9.8)
- [CVE-2022-46164](https://insights.sbomify.com/CVE-2022-46164/): Account takeover via prototype vulnerability (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-57041 and fix it if it is affected.

What it is: CVE-2024-57041 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Jan 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57041 exists.

Affected packages and fixed versions:
- nodebb (npm): affected all versions; fixed in 3.11.1
- nodebb (npm): affected all versions; fixed in 3.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-57041/ (Markdown: https://insights.sbomify.com/CVE-2024-57041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-57041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-57041
- OSV: https://osv.dev/vulnerability/CVE-2024-57041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-57041/
Summaries are generated and may contain mistakes; the official description above is the record.
