# CVE-2024-57082: @rpldy/uploader prototype pollution

> Attackers can cause a Denial of Service in the @rpldy/uploader library via prototype pollution in the createUploader function.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2025
- **Updated:** 18 Feb 2025
- **Also known as:** GHSA-pc47-g7gv-4gpw

## What is CVE-2024-57082?

CVE-2024-57082 is a medium-severity denial of service vulnerability in n/a, published on 5 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A prototype pollution in the lib.createUploader function of @rpldy/uploader v1.8.1 allows attackers to cause a Denial of Service (DoS) via supplying a crafted payload.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-57082?

2 open source packages ship an affected version, including @rpldy/uploader.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@rpldy/uploader` | npm | All versions | 1.9.1 |
| `@rpldy/uploader` | npm | All versions | 1.9.1 |

## How do I fix CVE-2024-57082?

Upgrade @rpldy/uploader to 1.9.1 or later.

## Is CVE-2024-57082 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57082 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-57082 and fix it if it is affected.

What it is: CVE-2024-57082 is a medium-severity denial of service vulnerability in n/a, published on 5 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57082 exists.

Affected packages and fixed versions:
- @rpldy/uploader (npm): affected all versions; fixed in 1.9.1
- @rpldy/uploader (npm): affected all versions; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-57082/ (Markdown: https://insights.sbomify.com/CVE-2024-57082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-57082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-57082
- OSV: https://osv.dev/vulnerability/CVE-2024-57082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-57082/
Summaries are generated and may contain mistakes; the official description above is the record.
