CVE-2024-5710 Improper Access Control in Team Management in berriai/litellm

Medium 5.3 Published Updated

Attackers can bypass authorization to create, modify, or delete teams and members in LiteLLM, compromising team management integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-5710?

CVE-2024-5710 is a medium-severity missing authorization vulnerability in berriai/litellm, published on 27 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

berriai/litellm version 1.34.34 is vulnerable to improper access control in its team management functionality. This vulnerability allows attackers to perform unauthorized actions such as creating, updating, viewing, deleting, blocking, and unblocking any teams, as well as adding or deleting any member to or from any teams. The vulnerability stems from insufficient access control checks in various team management endpoints, enabling attackers to exploit these functionalities without proper authorization.

Weakness: CWE-862

Which versions are affected by CVE-2024-5710?

3 open source packages ship an affected version, including litellm. It affects 1 product.

PackageAffectedFixed in
litellm PyPIAll versions1.40.15
litellm PyPIAll versions1.40.15
litellm PyPIAll versions1.40.15

Products include Litellm Litellm.

How do I fix CVE-2024-5710?

Upgrade litellm to 1.40.15 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-5710 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5710 exists.

Sources

Also known as GHSA-qqcv-vg9f-5rr3, PYSEC-2026-1551.

Is CVE-2024-5710 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free