# CVE-2024-5710: Improper Access Control in Team Management in berriai/litellm

> Attackers can bypass authorization to create, modify, or delete teams and members in LiteLLM, compromising team management integrity.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-qqcv-vg9f-5rr3, PYSEC-2026-1551

## What is CVE-2024-5710?

CVE-2024-5710 is a medium-severity missing authorization vulnerability in berriai/litellm, published on 27 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

berriai/litellm version 1.34.34 is vulnerable to improper access control in its team management functionality. This vulnerability allows attackers to perform unauthorized actions such as creating, updating, viewing, deleting, blocking, and unblocking any teams, as well as adding or deleting any member to or from any teams. The vulnerability stems from insufficient access control checks in various team management endpoints, enabling attackers to exploit these functionalities without proper authorization.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-5710?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.40.15 |
| `litellm` | PyPI | All versions | 1.40.15 |
| `litellm` | PyPI | All versions | 1.40.15 |

Products: Litellm Litellm.

## How do I fix CVE-2024-5710?

Upgrade litellm to 1.40.15 or later.

## Is CVE-2024-5710 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5710 exists.

## Other vulnerabilities in berriai/litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-5751](https://insights.sbomify.com/CVE-2024-5751/): Remote Code Execution in BerriAI/litellm (critical 9.8)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5710 and fix it if it is affected.

What it is: CVE-2024-5710 is a medium-severity missing authorization vulnerability in berriai/litellm, published on 27 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5710 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.40.15
- litellm (PyPI): affected all versions; fixed in 1.40.15
- litellm (PyPI): affected all versions; fixed in 1.40.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5710/ (Markdown: https://insights.sbomify.com/CVE-2024-5710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5710
- OSV: https://osv.dev/vulnerability/CVE-2024-5710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5710/
Summaries are generated and may contain mistakes; the official description above is the record.
