# CVE-2024-57186: Erxes Path Traversal vulnerability

> An unauthenticated attacker can read arbitrary files from the system via a path traversal vulnerability in the Erxes CRM application.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-rq9r-qvwg-829q

## What is CVE-2024-57186?

CVE-2024-57186 is a medium-severity path traversal vulnerability in n/a, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Erxes <1.6.2, an unauthenticated attacker can read arbitrary files from the system using a Path Traversal vulnerability in the /read-file endpoint handler.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-57186?

2 open source packages ship an affected version, including erxes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `erxes` | npm | All versions | 1.6.2 |
| `erxes` | npm | All versions | 1.6.2 |

Products: Erxes Erxes.

## How do I fix CVE-2024-57186?

Upgrade erxes to 1.6.2 or later.

## Is CVE-2024-57186 being exploited?

There is no known exploitation of CVE-2024-57186 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-57190](https://insights.sbomify.com/CVE-2024-57190/): Erxes Incorrect Access Control vulnerability (critical 9.8)
- [CVE-2021-32853](https://insights.sbomify.com/CVE-2021-32853/): Erxes vulnerable to Cross-site Scripting (medium 6.1)
- [CVE-2024-57189](https://insights.sbomify.com/CVE-2024-57189/): Erxes Path Traversal vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-57186 and fix it if it is affected.

What it is: CVE-2024-57186 is a medium-severity path traversal vulnerability in n/a, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-57186 in the wild and no public exploit code.

Affected packages and fixed versions:
- erxes (npm): affected all versions; fixed in 1.6.2
- erxes (npm): affected all versions; fixed in 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-57186/ (Markdown: https://insights.sbomify.com/CVE-2024-57186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-57186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-57186
- OSV: https://osv.dev/vulnerability/CVE-2024-57186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-57186/
Summaries are generated and may contain mistakes; the official description above is the record.
