# CVE-2024-57190: Erxes Incorrect Access Control vulnerability

> Attackers can bypass authentication in Erxes by spoofing the User HTTP header to access GraphQL endpoints.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-7rhv-xm4q-wh42

## What is CVE-2024-57190?

CVE-2024-57190 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Erxes <1.6.1 is vulnerable to Incorrect Access Control. An attacker can bypass authentication by providing a "User" HTTP header that contains any user, allowing them to talk to any GraphQL endpoint.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-57190?

2 open source packages ship an affected version, including erxes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `erxes` | npm | All versions | 1.6.1 |
| `erxes` | npm | All versions | 1.6.1 |

Products: Erxes Erxes.

## How do I fix CVE-2024-57190?

Upgrade erxes to 1.6.1 or later.

## Is CVE-2024-57190 being exploited?

There is no known exploitation of CVE-2024-57190 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-32853](https://insights.sbomify.com/CVE-2021-32853/): Erxes vulnerable to Cross-site Scripting (medium 6.1)
- [CVE-2024-57186](https://insights.sbomify.com/CVE-2024-57186/): Erxes Path Traversal vulnerability (medium 5.4)
- [CVE-2024-57189](https://insights.sbomify.com/CVE-2024-57189/): Erxes Path Traversal vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-57190 and fix it if it is affected.

What it is: CVE-2024-57190 is a critical authentication bypass vulnerability in n/a, published on 10 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-57190 in the wild and no public exploit code.

Affected packages and fixed versions:
- erxes (npm): affected all versions; fixed in 1.6.1
- erxes (npm): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-57190/ (Markdown: https://insights.sbomify.com/CVE-2024-57190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-57190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-57190
- OSV: https://osv.dev/vulnerability/CVE-2024-57190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-57190/
Summaries are generated and may contain mistakes; the official description above is the record.
