# CVE-2024-5751: Remote Code Execution in BerriAI/litellm

> Attackers can achieve remote code execution in LiteLLM by sending malicious payloads to the config update endpoint when Google KMS and database storage are enabled.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-gppg-gqw8-wh9g, PYSEC-2026-389

## What is CVE-2024-5751?

CVE-2024-5751 is a critical code injection vulnerability in berriai/litellm, published on 27 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

BerriAI/litellm version v1.35.8 contains a vulnerability where an attacker can achieve remote code execution. The vulnerability exists in the `add_deployment` function, which decodes and decrypts environment variables from base64 and assigns them to `os.environ`. An attacker can exploit this by sending a malicious payload to the `/config/update` endpoint, which is then processed and executed by the server when the `get_secret` function is triggered. This requires the server to use Google KMS and a database to store a model.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-5751?

3 open source packages ship an affected version, including litellm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.40.16 |
| `litellm` | PyPI | All versions | 1.40.16 |
| `litellm` | PyPI | All versions | 1.40.16 |

Products: Litellm Litellm.

## How do I fix CVE-2024-5751?

Upgrade litellm to 1.40.16 or later.

## Is CVE-2024-5751 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5751 exists.

## Other vulnerabilities in berriai/litellm

- [CVE-2026-42208](https://insights.sbomify.com/CVE-2026-42208/): BerriAI LiteLLM SQL Injection (critical 9.3, exploited in the wild)
- [CVE-2026-59822](https://insights.sbomify.com/CVE-2026-59822/): BerriAI LiteLLM Improper Authentication (high 8.8, exploited in the wild)
- [CVE-2026-42271](https://insights.sbomify.com/CVE-2026-42271/): BerriAI LiteLLM Command Injection (high 8.7, exploited in the wild)
- [CVE-2024-2952](https://insights.sbomify.com/CVE-2024-2952/): Server-Side Template Injection in BerriAI/litellm (critical 9.8)
- [CVE-2026-49468](https://insights.sbomify.com/CVE-2026-49468/): LiteLLM: Authentication Bypass via Host Header Injection (critical 9.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5751 and fix it if it is affected.

What it is: CVE-2024-5751 is a critical code injection vulnerability in berriai/litellm, published on 27 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5751 exists.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.40.16
- litellm (PyPI): affected all versions; fixed in 1.40.16
- litellm (PyPI): affected all versions; fixed in 1.40.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5751/ (Markdown: https://insights.sbomify.com/CVE-2024-5751/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5751
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5751
- OSV: https://osv.dev/vulnerability/CVE-2024-5751

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5751/
Summaries are generated and may contain mistakes; the official description above is the record.
