{"answers":{"affected":"2 open source packages ship an affected version, including store2. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57556 exists.","fix":"Upgrade store2 to 2.14.4 or later.","what":"CVE-2024-57556 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-57556 and fix it if it is affected.\n\nWhat it is: CVE-2024-57556 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57556 exists.\n\nAffected packages and fixed versions:\n- store2 (npm): affected all versions; fixed in 2.14.4\n- store2 (npm): affected all versions; fixed in 2.14.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-57556/ (Markdown: https://insights.sbomify.com/CVE-2024-57556/index.md)","id":"CVE-2024-57556","markdown":"https://insights.sbomify.com/CVE-2024-57556/index.md","name":"CVE-2024-57556","record":{"aliases":["GHSA-w5hq-hm5m-4548"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm store library","requires_auth":"none","summary":"A remote attacker can execute arbitrary code via Cross Site Scripting in the store.deep.js component of the nbubna store library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"store","vendor":"nbubna"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote attacker to execute arbitrary code via the store.deep.js component","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross Site Scripting vulnerability in store2","id":"CVE-2024-57556","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2024-57575"},"packages":[{"ecosystem":"npm","fixed":["2.14.4"],"introduced":["0"],"last_affected":[],"package":"store2","purl":null,"source":"GHSA-w5hq-hm5m-4548"},{"ecosystem":"npm","fixed":["2.14.4"],"introduced":["0"],"last_affected":[],"package":"store2","purl":"pkg:npm/store2","source":"GHSA-w5hq-hm5m-4548"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2024-57549"},"products":["n/a"],"published":"2025-01-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-24","vendors":["n/a"]},"summary":"A remote attacker can execute arbitrary code via Cross Site Scripting in the store.deep.js component of the nbubna store library.","url":"https://insights.sbomify.com/CVE-2024-57556/"}