# CVE-2024-57556: Cross Site Scripting vulnerability in store2

> A remote attacker can execute arbitrary code via Cross Site Scripting in the store.deep.js component of the nbubna store library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2025
- **Updated:** 24 Jan 2025
- **Also known as:** GHSA-w5hq-hm5m-4548

## What is CVE-2024-57556?

CVE-2024-57556 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote attacker to execute arbitrary code via the store.deep.js component

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-57556?

2 open source packages ship an affected version, including store2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `store2` | npm | All versions | 2.14.4 |
| `store2` | npm | All versions | 2.14.4 |

Products: Nbubna Store.

## How do I fix CVE-2024-57556?

Upgrade store2 to 2.14.4 or later.

## Is CVE-2024-57556 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57556 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-57556 and fix it if it is affected.

What it is: CVE-2024-57556 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57556 exists.

Affected packages and fixed versions:
- store2 (npm): affected all versions; fixed in 2.14.4
- store2 (npm): affected all versions; fixed in 2.14.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-57556/ (Markdown: https://insights.sbomify.com/CVE-2024-57556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-57556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-57556
- OSV: https://osv.dev/vulnerability/CVE-2024-57556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-57556/
Summaries are generated and may contain mistakes; the official description above is the record.
