CVE-2024-57699 Netplex Json-smart Uncontrolled Recursion vulnerability
Attackers can cause a Denial of Service in Netplex Json-smart by sending crafted JSON with excessive braces, triggering stack exhaustion.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-57699?
CVE-2024-57699 is a high-severity denial of service vulnerability in n/a, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A security issue was found in Netplex Json-smart 2.5.0 through 2.5.1. When loading a specially crafted JSON input, containing a large number of ’{’, a stack exhaustion can be trigger, which could allow an attacker to cause a Denial of Service (DoS). This issue exists because of an incomplete fix for CVE-2023-1370.
Weakness: CWE-674
Which versions are affected by CVE-2024-57699?
2 open source packages ship an affected version, including net.minidev:json-smart.
| Package | Affected | Fixed in |
|---|---|---|
net.minidev:json-smart Maven | From 2.5.0 | 2.5.2 |
net.minidev:json-smart Maven | From 2.5.0 | 2.5.2 |
How do I fix CVE-2024-57699?
Upgrade net.minidev:json-smart to 2.5.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-57699 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57699 exists.
Sources
Also known as CLEANSTART-2026-BE42282, CLEANSTART-2026-KK34525, CLSA-2026-1788528539, CLSA-2026-1789461217, DEBIAN-CVE-2024-57699, ECHO-5b91-c100-b90d and 9 more.