# CVE-2024-57699: Netplex Json-smart Uncontrolled Recursion vulnerability

> Attackers can cause a Denial of Service in Netplex Json-smart by sending crafted JSON with excessive braces, triggering stack exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2025
- **Updated:** 6 Feb 2025
- **Also known as:** CLEANSTART-2026-BE42282, CLEANSTART-2026-KK34525, CLSA-2026-1788528539, CLSA-2026-1789461217, DEBIAN-CVE-2024-57699, ECHO-5b91-c100-b90d, GHSA-pq2g-wx69-c263, MINI-5cqj-3g5v-vhrv, MINI-65vv-wjpq-gfw6, MINI-fv6c-69p9-jf77, OESA-2025-1164, RHLW-2026-90932e54c65972cd, RHLW-2026-c44e4cf8dcda3e35, ROOT-APP-MAVEN-CVE-2024-57699, UBUNTU-CVE-2024-57699

## What is CVE-2024-57699?

CVE-2024-57699 is a high-severity denial of service vulnerability in n/a, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A security issue was found in Netplex Json-smart 2.5.0 through 2.5.1. When loading a specially crafted JSON input, containing a large number of ’{’, a stack exhaustion can be trigger, which could allow an attacker to cause a Denial of Service (DoS). This issue exists because of an incomplete fix for CVE-2023-1370.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2024-57699?

2 open source packages ship an affected version, including net.minidev:json-smart.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.minidev:json-smart` | Maven | From 2.5.0 | 2.5.2 |
| `net.minidev:json-smart` | Maven | From 2.5.0 | 2.5.2 |

## How do I fix CVE-2024-57699?

Upgrade net.minidev:json-smart to 2.5.2 or later.

## Is CVE-2024-57699 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57699 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-57699 and fix it if it is affected.

What it is: CVE-2024-57699 is a high-severity denial of service vulnerability in n/a, published on 5 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-57699 exists.

Affected packages and fixed versions:
- net.minidev:json-smart (Maven): affected from 2.5.0; fixed in 2.5.2
- net.minidev:json-smart (Maven): affected from 2.5.0; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-57699/ (Markdown: https://insights.sbomify.com/CVE-2024-57699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-57699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-57699
- OSV: https://osv.dev/vulnerability/CVE-2024-57699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-57699/
Summaries are generated and may contain mistakes; the official description above is the record.
