CVE-2024-5795 Denial of Service vulnerability was identified in GitHub Enterprise Server that allowed resource exhaustion

High 7.7 Published Updated

An attacker can cause resource exhaustion in GitHub Enterprise Server by sending large payloads to the Git server, leading to denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-5795?

CVE-2024-5795 is a high-severity denial of service vulnerability in Github Enterprise Server, published on 16 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Denial of Service vulnerability was identified in GitHub Enterprise Server that allowed an attacker to cause unbounded resource exhaustion by sending a large payload to the Git server. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-400

Which versions are affected by CVE-2024-5795?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2024-5795?

No fix has been published for CVE-2024-5795 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-5795 being exploited?

There is no known exploitation of CVE-2024-5795 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-jwvr-83h7-5ch5.

Is CVE-2024-5795 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free