{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-57970 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-57970 is a medium-severity memory corruption vulnerability in libarchive, published on 16 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-57970 and fix it if it is affected.\n\nWhat it is: CVE-2024-57970 is a medium-severity memory corruption vulnerability in libarchive, published on 16 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-57970 in the wild and no public exploit code.\n\nAffected product: libarchive. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-57970/ (Markdown: https://insights.sbomify.com/CVE-2024-57970/index.md)","id":"CVE-2024-57970","markdown":"https://insights.sbomify.com/CVE-2024-57970/index.md","name":"CVE-2024-57970","record":{"aliases":["ALPINE-CVE-2024-57970","ALSA-2025:7510","BELL-CVE-2024-57970","GHSA-2q66-6w43-8rm9","JLSEC-2025-250","MINI-5h6q-fffc-fp96","RHSA-2025:7510","RLSA-2025:7510","openSUSE-SU-2025:14844-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"libarchive library","requires_auth":"none","summary":"A heap-based buffer over-read in libarchive allows attackers to cause denial of service or disclose information via a crafted TAR archive.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-126","name":"Buffer Over-read"}],"description":"libarchive through 3.7.7 has a heap-based buffer over-read in header_gnu_longlink in archive_read_support_format_tar.c via a TAR archive because it mishandles truncation in the middle of a GNU long linkname.","ecosystems":["AlmaLinux:10","Red Hat:enterprise_linux:10.0","Rocky Linux:10","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in libarchive","id":"CVE-2024-57970","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":14,"n_references":2,"next":{"headline":"Other in KNOWAGE","id":"CVE-2024-57971"},"packages":[{"ecosystem":"AlmaLinux:10","fixed":["3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"bsdtar","purl":"pkg:rpm/almalinux/bsdtar","source":"ALSA-2025:7510"},{"ecosystem":"AlmaLinux:10","fixed":["3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"libarchive","purl":"pkg:rpm/almalinux/libarchive","source":"ALSA-2025:7510"},{"ecosystem":"AlmaLinux:10","fixed":["3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"libarchive-devel","purl":"pkg:rpm/almalinux/libarchive-devel","source":"ALSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"bsdcat-debuginfo","purl":"pkg:rpm/redhat/bsdcat-debuginfo","source":"RHSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"bsdcpio-debuginfo","purl":"pkg:rpm/redhat/bsdcpio-debuginfo","source":"RHSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"bsdtar","purl":"pkg:rpm/redhat/bsdtar","source":"RHSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"bsdtar-debuginfo","purl":"pkg:rpm/redhat/bsdtar-debuginfo","source":"RHSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"bsdunzip-debuginfo","purl":"pkg:rpm/redhat/bsdunzip-debuginfo","source":"RHSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"libarchive","purl":"pkg:rpm/redhat/libarchive","source":"RHSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"libarchive-debuginfo","purl":"pkg:rpm/redhat/libarchive-debuginfo","source":"RHSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"libarchive-debugsource","purl":"pkg:rpm/redhat/libarchive-debugsource","source":"RHSA-2025:7510"},{"ecosystem":"Red Hat:enterprise_linux:10.0","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"libarchive-devel","purl":"pkg:rpm/redhat/libarchive-devel","source":"RHSA-2025:7510"},{"ecosystem":"Rocky Linux:10","fixed":["0:3.7.7-2.el10_0"],"introduced":["0"],"last_affected":[],"package":"libarchive","purl":"pkg:rpm/rocky-linux/libarchive?distro=rocky-linux-10-0\u0026epoch=0","source":"RLSA-2025:7510"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.7.7-2.1"],"introduced":["0"],"last_affected":[],"package":"libarchive","purl":"pkg:rpm/opensuse/libarchive\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14844-1"}],"prev":{"headline":"Missing authorization in MISP","id":"CVE-2024-57969"},"products":["libarchive"],"published":"2025-02-16","related":[],"sources":[{"class":"attribution","licence":"MIT","name":"AlmaLinux","prefix":"ALSA"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"BSD","name":"Rocky Linux","prefix":"RLSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-18","vendors":["libarchive"]},"summary":"A heap-based buffer over-read in libarchive allows attackers to cause denial of service or disclose information via a crafted TAR archive.","url":"https://insights.sbomify.com/CVE-2024-57970/"}