# CVE-2024-58103: Wire has Uncontrolled Recursion on Nested Groups

> Attackers can cause denial of service by sending deeply nested protocol buffer messages to applications using Square Wire.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2025
- **Updated:** 17 Mar 2025
- **Also known as:** GHSA-pwf9-q62p-v7wc

## What is CVE-2024-58103?

CVE-2024-58103 is a medium-severity denial of service vulnerability in Square Wire, published on 16 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Square Wire before 5.2.0 does not enforce a recursion limit on nested groups in ByteArrayProtoReader32.kt and ProtoReader.kt.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2024-58103?

2 open source packages ship an affected version, including com.squareup.wire:wire-runtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.squareup.wire:wire-runtime` | Maven | All versions | 5.2.0 |
| `com.squareup.wire:wire-runtime` | Maven | All versions | 5.2.0 |

## How do I fix CVE-2024-58103?

Upgrade com.squareup.wire:wire-runtime to 5.2.0 or later.

## Is CVE-2024-58103 being exploited?

There is no known exploitation of CVE-2024-58103 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58103 and fix it if it is affected.

What it is: CVE-2024-58103 is a medium-severity denial of service vulnerability in Square Wire, published on 16 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58103 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.squareup.wire:wire-runtime (Maven): affected all versions; fixed in 5.2.0
- com.squareup.wire:wire-runtime (Maven): affected all versions; fixed in 5.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58103/ (Markdown: https://insights.sbomify.com/CVE-2024-58103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58103
- OSV: https://osv.dev/vulnerability/CVE-2024-58103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58103/
Summaries are generated and may contain mistakes; the official description above is the record.
