CVE-2024-5817 Improper authorization allows read access to issue content in GitHub Enterprise Server

Medium 5.9 Published Updated

An attacker with project board access can read issue content in internal repositories due to improper authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-5817?

CVE-2024-5817 is a medium-severity missing authorization vulnerability in Github Enterprise Server, published on 16 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed read access to issue content via GitHub Projects. This was only exploitable in internal repositories and required the attacker to have access to the corresponding project board. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-863

Which versions are affected by CVE-2024-5817?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2024-5817?

No fix has been published for CVE-2024-5817 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-5817 being exploited?

There is no known exploitation of CVE-2024-5817 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-hf94-2x3f-x6rc.

Is CVE-2024-5817 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free