{"answers":{"affected":"3 open source packages ship an affected version, including lollms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5824 exists.","fix":"Upgrade lollms to 9.5.0 or later.","what":"CVE-2024-5824 is a high-severity path traversal vulnerability in parisneo/lollms, published on 27 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-5824 and fix it if it is affected.\n\nWhat it is: CVE-2024-5824 is a high-severity path traversal vulnerability in parisneo/lollms, published on 27 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5824 exists.\n\nAffected packages and fixed versions:\n- lollms (PyPI): affected all versions; fixed in 9.5.0\n- lollms (PyPI): affected all versions; fixed in 9.5.0\n- lollms (PyPI): affected all versions; fixed in 9.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-5824/ (Markdown: https://insights.sbomify.com/CVE-2024-5824/index.md)","id":"CVE-2024-5824","markdown":"https://insights.sbomify.com/CVE-2024-5824/index.md","name":"CVE-2024-5824","record":{"aliases":["GHSA-m45c-v46h-c788","PYSEC-2026-1592"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"lollms web application","requires_auth":"none","summary":"Attackers can exploit a path traversal flaw to overwrite configuration files, enabling remote code execution in lollms.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A path traversal vulnerability in the `/set_personality_config` endpoint of parisneo/lollms version 9.4.0 allows an attacker to overwrite the `configs/config.yaml` file. This can lead to remote code execution by changing server configuration properties such as `force_accept_remote_access` and `turn_on_code_validation`.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Path Traversal in parisneo/lollms","id":"CVE-2024-5824","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2024-5825"},"packages":[{"ecosystem":"PyPI","fixed":["9.5.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":null,"source":"GHSA-m45c-v46h-c788"},{"ecosystem":"PyPI","fixed":["9.5.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"GHSA-m45c-v46h-c788"},{"ecosystem":"PyPI","fixed":["9.5.0"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"PYSEC-2026-1592"}],"prev":{"headline":"File Overwrite Vulnerability in gaizhenbiao/chuanhuchatgpt","id":"CVE-2024-5823"},"products":["parisneo/lollms"],"published":"2024-06-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["parisneo"]},"summary":"Attackers can exploit a path traversal flaw to overwrite configuration files, enabling remote code execution in lollms.","url":"https://insights.sbomify.com/CVE-2024-5824/"}