# CVE-2024-5824: Path Traversal in parisneo/lollms

> Attackers can exploit a path traversal flaw to overwrite configuration files, enabling remote code execution in lollms.

- **Severity:** High 7.4 (`CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jun 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-m45c-v46h-c788, PYSEC-2026-1592

## What is CVE-2024-5824?

CVE-2024-5824 is a high-severity path traversal vulnerability in parisneo/lollms, published on 27 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A path traversal vulnerability in the `/set_personality_config` endpoint of parisneo/lollms version 9.4.0 allows an attacker to overwrite the `configs/config.yaml` file. This can lead to remote code execution by changing server configuration properties such as `force_accept_remote_access` and `turn_on_code_validation`.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-5824?

3 open source packages ship an affected version, including lollms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 9.5.0 |
| `lollms` | PyPI | All versions | 9.5.0 |
| `lollms` | PyPI | All versions | 9.5.0 |

## How do I fix CVE-2024-5824?

Upgrade lollms to 9.5.0 or later.

## Is CVE-2024-5824 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5824 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5824 and fix it if it is affected.

What it is: CVE-2024-5824 is a high-severity path traversal vulnerability in parisneo/lollms, published on 27 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5824 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 9.5.0
- lollms (PyPI): affected all versions; fixed in 9.5.0
- lollms (PyPI): affected all versions; fixed in 9.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5824/ (Markdown: https://insights.sbomify.com/CVE-2024-5824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5824
- OSV: https://osv.dev/vulnerability/CVE-2024-5824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5824/
Summaries are generated and may contain mistakes; the official description above is the record.
