{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-58249 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-58249 is a low-severity denial of service vulnerability in wxWidgets, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-58249 and fix it if it is affected.\n\nWhat it is: CVE-2024-58249 is a low-severity denial of service vulnerability in wxWidgets, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-58249 in the wild and no public exploit code.\n\nAffected product: wxWidgets. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-58249/ (Markdown: https://insights.sbomify.com/CVE-2024-58249/index.md)","id":"CVE-2024-58249","markdown":"https://insights.sbomify.com/CVE-2024-58249/index.md","name":"CVE-2024-58249","record":{"aliases":["DEBIAN-CVE-2024-58249","GHSA-643m-q4f3-rfc2","JLSEC-2026-1262","MGASA-2025-0217","OESA-2025-1504","OESA-2025-1505","SUSE-SU-2025:01735-1","UBUNTU-CVE-2024-58249","openSUSE-SU-2025:15309-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"wxWidgets library","requires_auth":"none","summary":"An attacker can cause a crash in wxWidgets applications by triggering refused connections in the web request component.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-826","name":"Premature Release of Resource During Expected Lifetime"}],"description":"In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.","ecosystems":["SUSE:Linux Enterprise Module for Package Hub 15 SP6","SUSE:Linux Enterprise Module for Package Hub 15 SP7","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in wxWidgets","id":"CVE-2024-58249","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":11,"n_references":3,"next":{"headline":"Privilege escalation in ppp","id":"CVE-2024-58250"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxGTK3-3_2","purl":"pkg:rpm/suse/wxGTK3-3_2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxQt-3_2","purl":"pkg:rpm/suse/wxQt-3_2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxWidgets-3_2","purl":"pkg:rpm/suse/wxWidgets-3_2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxGTK3-3_2","purl":"pkg:rpm/suse/wxGTK3-3_2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxQt-3_2","purl":"pkg:rpm/suse/wxQt-3_2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP7","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxWidgets-3_2","purl":"pkg:rpm/suse/wxWidgets-3_2\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP7","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxGTK3-3_2","purl":"pkg:rpm/opensuse/wxGTK3-3_2\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxQt-3_2","purl":"pkg:rpm/opensuse/wxQt-3_2\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxWidgets-3_2","purl":"pkg:rpm/opensuse/wxWidgets-3_2\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["3.1.5-150400.3.10.1"],"introduced":["0"],"last_affected":[],"package":"wxWidgets-3_2-nostl","purl":"pkg:rpm/opensuse/wxWidgets-3_2-nostl\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:01735-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.2.8-4.1"],"introduced":["0"],"last_affected":[],"package":"wxWidgets-3_2","purl":"pkg:rpm/opensuse/wxWidgets-3_2\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15309-1"}],"prev":{"headline":"Race condition in nopCommerce","id":"CVE-2024-58248"},"products":["wxWidgets"],"published":"2025-04-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-17","vendors":["wxWidgets"]},"summary":"An attacker can cause a crash in wxWidgets applications by triggering refused connections in the web request component.","url":"https://insights.sbomify.com/CVE-2024-58249/"}