{"answers":{"affected":"2 open source packages ship an affected version, including obfstr.","exploited":"There is no known exploitation of CVE-2024-58253 in the wild and no public exploit code.","fix":"Upgrade obfstr to 0.4.4 or later.","what":"CVE-2024-58253 is a low-severity vulnerability in CasualX obfstr, published on 2 May 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-58253 and fix it if it is affected.\n\nWhat it is: CVE-2024-58253 is a low-severity vulnerability in CasualX obfstr, published on 2 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-58253 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- obfstr (crates.io): affected all versions; fixed in 0.4.4\n- obfstr (crates.io): affected all versions; fixed in 0.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-58253/ (Markdown: https://insights.sbomify.com/CVE-2024-58253/index.md)","id":"CVE-2024-58253","markdown":"https://insights.sbomify.com/CVE-2024-58253/index.md","name":"CVE-2024-58253","record":{"aliases":["GHSA-v2p5-q653-9j99"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust obfuscation library","requires_auth":"none","summary":"The obfstr crate allows invalid UTF-8 conversion due to unrestricted argument types, potentially causing runtime errors or undefined behavior in Rust applications.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"In the obfstr crate before 0.4.4 for Rust, the obfstr! argument type is not restricted to string slices, leading to invalid UTF-8 conversion that produces an invalid value.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"obfstr Type Confusion vulnerability","id":"CVE-2024-58253","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Command injection in EnzoH-W5611T","id":"CVE-2024-58255"},"packages":[{"ecosystem":"crates.io","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"obfstr","purl":null,"source":"GHSA-v2p5-q653-9j99"},{"ecosystem":"crates.io","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"obfstr","purl":"pkg:cargo/obfstr","source":"GHSA-v2p5-q653-9j99"}],"prev":{"headline":"Information disclosure in HarmonyOS","id":"CVE-2024-58252"},"products":["obfstr"],"published":"2025-05-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-05","vendors":["CasualX"]},"summary":"The obfstr crate allows invalid UTF-8 conversion due to unrestricted argument types, potentially causing runtime errors or undefined behavior in Rust applications.","url":"https://insights.sbomify.com/CVE-2024-58253/"}