{"answers":{"affected":"3 open source packages ship an affected version, including sequoia-openpgp. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58261 exists.","fix":"Upgrade sequoia-openpgp to 1.21.0 or later.","what":"CVE-2024-58261 is a low-severity denial of service vulnerability in sequoia-pgp sequoia, published on 27 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-58261 and fix it if it is affected.\n\nWhat it is: CVE-2024-58261 is a low-severity denial of service vulnerability in sequoia-pgp sequoia, published on 27 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58261 exists.\n\nAffected packages and fixed versions:\n- sequoia-openpgp (crates.io): affected from 1.13.0; fixed in 1.21.0\n- sequoia-openpgp (crates.io): affected from 1.13.0; fixed in 1.21.0\n- sequoia-openpgp (crates.io): affected from 1.13.0; fixed in 1.21.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-58261/ (Markdown: https://insights.sbomify.com/CVE-2024-58261/index.md)","id":"CVE-2024-58261","markdown":"https://insights.sbomify.com/CVE-2024-58261/index.md","name":"CVE-2024-58261","record":{"aliases":["DEBIAN-CVE-2024-58261","GHSA-9344-p847-qm5c","RUSTSEC-2024-0345","UBUNTU-CVE-2024-58261"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust PGP library","requires_auth":"none","summary":"Attackers can cause a denial of service via infinite loop in the sequoia-openpgp Rust library when parsing unsupported primary key types.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"sequoia-openpgp","vendor":"sequoia-pgp"}],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"The sequoia-openpgp crate 1.13.0 before 1.21.0 for Rust allows an infinite loop of \"Reading a cert: Invalid operation: Not a Key packet\" messages for RawCertParser operations that encounter an unsupported primary key type.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Low severity (DoS) vulnerability in sequoia-openpgp","id":"CVE-2024-58261","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"curve25519-dalek has timing variability in `curve25519-dalek`'s `Scalar29::sub`/`Scalar52::sub`","id":"CVE-2024-58262"},"packages":[{"ecosystem":"crates.io","fixed":["1.21.0"],"introduced":["1.13.0"],"last_affected":[],"package":"sequoia-openpgp","purl":null,"source":"GHSA-9344-p847-qm5c"},{"ecosystem":"crates.io","fixed":["1.21.0"],"introduced":["1.13.0"],"last_affected":[],"package":"sequoia-openpgp","purl":"pkg:cargo/sequoia-openpgp","source":"GHSA-9344-p847-qm5c"},{"ecosystem":"crates.io","fixed":["1.21.0"],"introduced":["1.13.0"],"last_affected":[],"package":"sequoia-openpgp","purl":"pkg:cargo/sequoia-openpgp","source":"RUSTSEC-2024-0345"}],"prev":{"headline":"Rancher update on users can deny the service to the admin","id":"CVE-2024-58260"},"products":["sequoia"],"published":"2025-07-27","related":[{"cvss_score":2.9,"headline":"sequoia-openpgp vulnerable to out-of-bounds array access leading to panic","id":"CVE-2023-53160","kev_date_added":null,"published":"2025-07-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-07-28","vendors":["sequoia-pgp"]},"summary":"Attackers can cause a denial of service via infinite loop in the sequoia-openpgp Rust library when parsing unsupported primary key types.","url":"https://insights.sbomify.com/CVE-2024-58261/"}