# CVE-2024-58261: Low severity (DoS) vulnerability in sequoia-openpgp

> Attackers can cause a denial of service via infinite loop in the sequoia-openpgp Rust library when parsing unsupported primary key types.

- **Severity:** Low 2.9 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** DEBIAN-CVE-2024-58261, GHSA-9344-p847-qm5c, RUSTSEC-2024-0345, UBUNTU-CVE-2024-58261

## What is CVE-2024-58261?

CVE-2024-58261 is a low-severity denial of service vulnerability in sequoia-pgp sequoia, published on 27 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The sequoia-openpgp crate 1.13.0 before 1.21.0 for Rust allows an infinite loop of "Reading a cert: Invalid operation: Not a Key packet" messages for RawCertParser operations that encounter an unsupported primary key type.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-58261?

3 open source packages ship an affected version, including sequoia-openpgp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sequoia-openpgp` | crates.io | From 1.13.0 | 1.21.0 |
| `sequoia-openpgp` | crates.io | From 1.13.0 | 1.21.0 |
| `sequoia-openpgp` | crates.io | From 1.13.0 | 1.21.0 |

Products: Sequoia-Pgp Sequoia-Openpgp.

## How do I fix CVE-2024-58261?

Upgrade sequoia-openpgp to 1.21.0 or later.

## Is CVE-2024-58261 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58261 exists.

## Other vulnerabilities in sequoia-pgp sequoia

- [CVE-2023-53160](https://insights.sbomify.com/CVE-2023-53160/): sequoia-openpgp vulnerable to out-of-bounds array access leading to panic (low 2.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58261 and fix it if it is affected.

What it is: CVE-2024-58261 is a low-severity denial of service vulnerability in sequoia-pgp sequoia, published on 27 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58261 exists.

Affected packages and fixed versions:
- sequoia-openpgp (crates.io): affected from 1.13.0; fixed in 1.21.0
- sequoia-openpgp (crates.io): affected from 1.13.0; fixed in 1.21.0
- sequoia-openpgp (crates.io): affected from 1.13.0; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58261/ (Markdown: https://insights.sbomify.com/CVE-2024-58261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58261
- OSV: https://osv.dev/vulnerability/CVE-2024-58261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58261/
Summaries are generated and may contain mistakes; the official description above is the record.
