CVE-2024-58263 CosmWasm affected by arithmetic overflows
Integer overflows in the cosmwasm-std Rust library can lead to incorrect smart contract calculations, potentially compromising data integrity.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-58263?
CVE-2024-58263 is a low-severity vulnerability in cosmwasm-std, published on 27 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The cosmwasm-std crate before 2.0.2 for Rust allows integer overflows that cause incorrect contract calculations.
Weakness: CWE-190
Which versions are affected by CVE-2024-58263?
7 open source packages ship an affected version, including cosmwasm-std. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cosmwasm-std crates.io | From 1.3.0 | 1.4.4, 1.5.4, 2.0.2 |
cosmwasm-std crates.io | From 1.3.0 | 1.4.4 |
cosmwasm-std crates.io | From 1.3.0 | 1.4.4 |
cosmwasm-std crates.io | From 1.5.0 | 1.5.4 |
cosmwasm-std crates.io | From 1.5.0 | 1.5.4 |
cosmwasm-std crates.io | From 2.0.0 | 2.0.2 |
1 more packages
cosmwasm-std crates.io | From 2.0.0 | 2.0.2 |
Products include Cosmwasm Cosmwasm-Std.
How do I fix CVE-2024-58263?
Upgrade cosmwasm-std to a fixed version for your release line: 1.4.4, 1.5.4 or 2.0.2.
Is CVE-2024-58263 being exploited?
There is no known exploitation of CVE-2024-58263 in the wild and no public exploit code.
Sources
Also known as GHSA-8724-5xmm-w5xq, RUSTSEC-2024-0338.