# CVE-2024-58263: CosmWasm affected by arithmetic overflows

> Integer overflows in the cosmwasm-std Rust library can lead to incorrect smart contract calculations, potentially compromising data integrity.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** GHSA-8724-5xmm-w5xq, RUSTSEC-2024-0338

## What is CVE-2024-58263?

CVE-2024-58263 is a low-severity vulnerability in cosmwasm-std, published on 27 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The cosmwasm-std crate before 2.0.2 for Rust allows integer overflows that cause incorrect contract calculations.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2024-58263?

7 open source packages ship an affected version, including cosmwasm-std. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cosmwasm-std` | crates.io | From 1.3.0 | 1.4.4, 1.5.4, 2.0.2 |
| `cosmwasm-std` | crates.io | From 1.3.0 | 1.4.4 |
| `cosmwasm-std` | crates.io | From 1.3.0 | 1.4.4 |
| `cosmwasm-std` | crates.io | From 1.5.0 | 1.5.4 |
| `cosmwasm-std` | crates.io | From 1.5.0 | 1.5.4 |
| `cosmwasm-std` | crates.io | From 2.0.0 | 2.0.2 |
| `cosmwasm-std` | crates.io | From 2.0.0 | 2.0.2 |

Products: Cosmwasm Cosmwasm-Std.

## How do I fix CVE-2024-58263?

Upgrade cosmwasm-std to a fixed version for your release line: 1.4.4, 1.5.4 or 2.0.2.

## Is CVE-2024-58263 being exploited?

There is no known exploitation of CVE-2024-58263 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58263 and fix it if it is affected.

What it is: CVE-2024-58263 is a low-severity vulnerability in cosmwasm-std, published on 27 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58263 in the wild and no public exploit code.

Affected packages and fixed versions:
- cosmwasm-std (crates.io): affected from 1.3.0; fixed in 1.4.4, 1.5.4, 2.0.2
- cosmwasm-std (crates.io): affected from 1.3.0; fixed in 1.4.4
- cosmwasm-std (crates.io): affected from 1.3.0; fixed in 1.4.4
- cosmwasm-std (crates.io): affected from 1.5.0; fixed in 1.5.4
- cosmwasm-std (crates.io): affected from 1.5.0; fixed in 1.5.4
- cosmwasm-std (crates.io): affected from 2.0.0; fixed in 2.0.2
- cosmwasm-std (crates.io): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58263/ (Markdown: https://insights.sbomify.com/CVE-2024-58263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58263
- OSV: https://osv.dev/vulnerability/CVE-2024-58263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58263/
Summaries are generated and may contain mistakes; the official description above is the record.
