CVE-2024-58264 serde-json-wasm stack overflow during recursive JSON parsing
Attackers can cause stack exhaustion and denial of service by sending deeply nested JSON data to applications using the serde-json-wasm crate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-58264?
CVE-2024-58264 is a low-severity denial of service vulnerability in CosmWasm serde-json-wasm, published on 27 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
The serde-json-wasm crate before 1.0.1 for Rust allows stack consumption via deeply nested JSON data.
Which versions are affected by CVE-2024-58264?
5 open source packages ship an affected version, including serde-json-wasm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
serde-json-wasm crates.io | All versions | 0.5.2 |
serde-json-wasm crates.io | All versions | 0.5.2 |
serde-json-wasm crates.io | From 0.0.0-0 | 0.5.2, 1.0.1 |
serde-json-wasm crates.io | From 1.0.0 | 1.0.1 |
serde-json-wasm crates.io | From 1.0.0 | 1.0.1 |
Products include Cosmwasm Serde-Json-Wasm.
How do I fix CVE-2024-58264?
Upgrade serde-json-wasm to a fixed version for your release line: 0.5.2 or 1.0.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-58264 being exploited?
There is no known exploitation of CVE-2024-58264 in the wild and no public exploit code.
Sources
Also known as GHSA-rr69-rxr6-8qwf, RUSTSEC-2024-0012.