# CVE-2024-58265: Unauthenticated Nonce Increment in snow

> Attackers can deny message delivery by incrementing nonces in stateful TransportState, affecting Rust applications using the snow crate.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2025
- **Updated:** 28 Jul 2025
- **Also known as:** DEBIAN-CVE-2024-58265, GHSA-7g9j-g5jg-3vv3, RUSTSEC-2024-0011, UBUNTU-CVE-2024-58265

## What is CVE-2024-58265?

CVE-2024-58265 is a low-severity denial of service vulnerability in mcginty snow, published on 27 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The snow crate before 0.9.5 for Rust, when stateful TransportState is used, allows incrementing a nonce and thereby denying message delivery.

Weakness: CWE-642 (External Control of Critical State Data)

## Which versions are affected by CVE-2024-58265?

3 open source packages ship an affected version, including snow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snow` | crates.io | All versions | 0.9.5 |
| `snow` | crates.io | All versions | 0.9.5 |
| `snow` | crates.io | From 0.0.0-0 | 0.9.5 |

Products: Mcginty Snow.

## How do I fix CVE-2024-58265?

Upgrade snow to 0.9.5 or later.

## Is CVE-2024-58265 being exploited?

There is no known exploitation of CVE-2024-58265 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58265 and fix it if it is affected.

What it is: CVE-2024-58265 is a low-severity denial of service vulnerability in mcginty snow, published on 27 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58265 in the wild and no public exploit code.

Affected packages and fixed versions:
- snow (crates.io): affected all versions; fixed in 0.9.5
- snow (crates.io): affected all versions; fixed in 0.9.5
- snow (crates.io): affected from 0.0.0-0; fixed in 0.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58265/ (Markdown: https://insights.sbomify.com/CVE-2024-58265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58265
- OSV: https://osv.dev/vulnerability/CVE-2024-58265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58265/
Summaries are generated and may contain mistakes; the official description above is the record.
