# CVE-2024-58339: LlamaIndex <= 0.12.2 VannaQueryEngine SQL Execution Allows Resource Exhaustion

> Attackers can cause denial of service by submitting prompts that trigger unbounded SQL execution in LlamaIndex's VannaQueryEngine.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-h7v7-pr65-4w53, PYSEC-2026-86

## What is CVE-2024-58339?

CVE-2024-58339 is a high-severity denial of service vulnerability in run-llama llama_index, published on 12 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LlamaIndex (run-llama/llama_index) versions up to and including 0.12.2 contain an uncontrolled resource consumption vulnerability in the VannaPack VannaQueryEngine implementation. The custom_query() logic generates SQL statements from a user-supplied prompt and executes them via vn.run_sql() without enforcing query execution limits In downstream deployments where untrusted users can supply prompts, an attacker can trigger expensive or unbounded SQL operations that exhaust CPU or memory resources, resulting in a denial-of-service condition. The vulnerable execution path occurs in llama_index/packs/vanna/base.py within custom_query().

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-58339?

1 open source package ship an affected version, including llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index` | PyPI | All versions | 0.12.3 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2024-58339?

Upgrade llama-index to 0.12.3 or later.

## Is CVE-2024-58339 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58339 exists.

## Other vulnerabilities in run-llama llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58339 and fix it if it is affected.

What it is: CVE-2024-58339 is a high-severity denial of service vulnerability in run-llama llama_index, published on 12 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58339 exists.

Affected packages and fixed versions:
- llama-index (PyPI): affected all versions; fixed in 0.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58339/ (Markdown: https://insights.sbomify.com/CVE-2024-58339/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58339
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58339
- OSV: https://osv.dev/vulnerability/CVE-2024-58339

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58339/
Summaries are generated and may contain mistakes; the official description above is the record.
