{"answers":{"affected":"2 open source packages ship an affected version, including flowise.","exploited":"There is no known exploitation of CVE-2024-58351 in the wild and no public exploit code.","fix":"Upgrade flowise to 2.1.4 or later.","what":"CVE-2024-58351 is a critical code injection vulnerability in Flowise, published on 20 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-58351 and fix it if it is affected.\n\nWhat it is: CVE-2024-58351 is a critical code injection vulnerability in Flowise, published on 20 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-58351 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 2.1.4\n- flowise (npm): affected all versions; fixed in 2.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-58351/ (Markdown: https://insights.sbomify.com/CVE-2024-58351/index.md)","id":"CVE-2024-58351","markdown":"https://insights.sbomify.com/CVE-2024-58351/index.md","name":"CVE-2024-58351","record":{"aliases":["GHSA-5cph-wvm9-45gj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise AI platform","requires_auth":"none","summary":"Attackers can achieve remote code execution and denial of service in Flowise by injecting malicious configuration into the Chainflow execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Flowise - Remote Code Execution via overrideConfig Parameter","id":"CVE-2024-58351","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Landray OA Unauthenticated HQL Injection via wechatLoginHelper.do","id":"CVE-2024-58352"},"packages":[{"ecosystem":"npm","fixed":["2.1.4"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-5cph-wvm9-45gj"},{"ecosystem":"npm","fixed":["2.1.4"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-5cph-wvm9-45gj"}],"prev":{"headline":"Ghidra \u003c 11.2 - Use After Free in Sleigh Backend via Static Initialization Order","id":"CVE-2024-58350"},"products":["Flowise"],"published":"2026-06-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-22","vendors":["Flowise"]},"summary":"Attackers can achieve remote code execution and denial of service in Flowise by injecting malicious configuration into the Chainflow execution.","url":"https://insights.sbomify.com/CVE-2024-58351/"}