# CVE-2024-58351: Flowise - Remote Code Execution via overrideConfig Parameter

> Attackers can achieve remote code execution and denial of service in Flowise by injecting malicious configuration into the Chainflow execution.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-5cph-wvm9-45gj

## What is CVE-2024-58351?

CVE-2024-58351 is a critical code injection vulnerability in Flowise, published on 20 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-58351?

2 open source packages ship an affected version, including flowise.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 2.1.4 |
| `flowise` | npm | All versions | 2.1.4 |

## How do I fix CVE-2024-58351?

Upgrade flowise to 2.1.4 or later.

## Is CVE-2024-58351 being exploited?

There is no known exploitation of CVE-2024-58351 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58351 and fix it if it is affected.

What it is: CVE-2024-58351 is a critical code injection vulnerability in Flowise, published on 20 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58351 in the wild and no public exploit code.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 2.1.4
- flowise (npm): affected all versions; fixed in 2.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58351/ (Markdown: https://insights.sbomify.com/CVE-2024-58351/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58351
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58351
- OSV: https://osv.dev/vulnerability/CVE-2024-58351

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58351/
Summaries are generated and may contain mistakes; the official description above is the record.
