# CVE-2024-58356: SurrealDB before 2.1.4 Permission Bypass via DEFINE TABLE OVERWRITE

> Attackers can bypass intended table permission restrictions in SurrealDB due to a failure in the DEFINE TABLE OVERWRITE clause for relation tables.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-27vq-hv74-7cqp

## What is CVE-2024-58356?

CVE-2024-58356 is a low-severity missing authorization vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SurrealDB before 2.1.4 silently fails to overwrite table definitions when the DEFINE TABLE ... OVERWRITE clause is used on tables defined with TYPE RELATION. Because table definitions include the PERMISSIONS clause, an attempt to tighten a table's permissions via OVERWRITE does not take effect, and the administrator may incorrectly believe the change was applied. As a result, a client authorized to run queries may continue to access data in that table that the updated (but unapplied) permissions were intended to restrict.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2024-58356?

4 open source packages ship an affected version, including surrealdb and surrealdb-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surrealdb` | crates.io | From 2.0.0 | 2.1.4 |
| `surrealdb` | crates.io | From 2.0.0 | 2.1.4 |
| `surrealdb-core` | crates.io | From 2.0.0 | 2.1.4 |
| `surrealdb-core` | crates.io | From 2.0.0 | 2.1.4 |

Products: Surrealdb Surrealdb.

## How do I fix CVE-2024-58356?

Upgrade surrealdb to 2.1.4 or later.

## Is CVE-2024-58356 being exploited?

There is no known exploitation of CVE-2024-58356 in the wild and no public exploit code.

## Other vulnerabilities in Surrealdb Surrealdb

- [CVE-2025-71392](https://insights.sbomify.com/CVE-2025-71392/): SurrealDB before 2.2.2 SurrealQL Injection via export (critical 9.4)
- [CVE-2026-63756](https://insights.sbomify.com/CVE-2026-63756/): SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition (critical 9.2)
- [CVE-2026-63747](https://insights.sbomify.com/CVE-2026-63747/): SurrealDB before 3.1.0 Denial of Service via malformed RPC use (high 8.7)
- [CVE-2026-63757](https://insights.sbomify.com/CVE-2026-63757/): SurrealDB before 3.1.0 Session Hijacking via /rpc sessions (high 8.7)
- [CVE-2026-63760](https://insights.sbomify.com/CVE-2026-63760/): SurrealDB before 3.1.0 Denial of Service via JSON Parser (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58356 and fix it if it is affected.

What it is: CVE-2024-58356 is a low-severity missing authorization vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58356 in the wild and no public exploit code.

Affected packages and fixed versions:
- surrealdb (crates.io): affected from 2.0.0; fixed in 2.1.4
- surrealdb (crates.io): affected from 2.0.0; fixed in 2.1.4
- surrealdb-core (crates.io): affected from 2.0.0; fixed in 2.1.4
- surrealdb-core (crates.io): affected from 2.0.0; fixed in 2.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58356/ (Markdown: https://insights.sbomify.com/CVE-2024-58356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58356
- OSV: https://osv.dev/vulnerability/CVE-2024-58356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58356/
Summaries are generated and may contain mistakes; the official description above is the record.
