# CVE-2024-58363: SurrealDB before 1.5.4 Authentication Bypass via Database Switch

> Authenticated users can bypass authentication to impersonate others in different databases, enabling unauthorized data access and modification.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-gh9f-6xm2-c4j2

## What is CVE-2024-58363?

CVE-2024-58363 is a medium-severity authentication bypass vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SurrealDB before 1.5.4 and 2.0.0-alpha.1 before 2.0.0-alpha.6 fails to properly validate authentication when a scope user switches databases using the USE clause or use method. Attackers with an authenticated session can impersonate an unrelated user in a different database if a user record with an identical identifier exists, allowing unauthorized actions if permissions rely solely on the $auth parameter.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-58363?

6 open source packages ship an affected version, including surrealdb and surrealdb-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surrealdb` | crates.io | All versions | 1.5.4 |
| `surrealdb` | crates.io | All versions | 1.5.4 |
| `surrealdb` | crates.io | From 2.0.0-alpha.1 | 2.0.0-alpha.6 |
| `surrealdb` | crates.io | From 2.0.0-alpha.1 | 2.0.0-alpha.6 |
| `surrealdb-core` | crates.io | All versions | 1.5.1 |
| `surrealdb-core` | crates.io | All versions | 1.5.1 |

Products: Surrealdb Surrealdb.

## How do I fix CVE-2024-58363?

Upgrade surrealdb to a fixed version for your release line: 1.5.4 or 2.0.0-alpha.6.

## Is CVE-2024-58363 being exploited?

There is no known exploitation of CVE-2024-58363 in the wild and no public exploit code.

## Other vulnerabilities in Surrealdb Surrealdb

- [CVE-2025-71392](https://insights.sbomify.com/CVE-2025-71392/): SurrealDB before 2.2.2 SurrealQL Injection via export (critical 9.4)
- [CVE-2026-63756](https://insights.sbomify.com/CVE-2026-63756/): SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition (critical 9.2)
- [CVE-2026-63747](https://insights.sbomify.com/CVE-2026-63747/): SurrealDB before 3.1.0 Denial of Service via malformed RPC use (high 8.7)
- [CVE-2026-63757](https://insights.sbomify.com/CVE-2026-63757/): SurrealDB before 3.1.0 Session Hijacking via /rpc sessions (high 8.7)
- [CVE-2026-63760](https://insights.sbomify.com/CVE-2026-63760/): SurrealDB before 3.1.0 Denial of Service via JSON Parser (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58363 and fix it if it is affected.

What it is: CVE-2024-58363 is a medium-severity authentication bypass vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58363 in the wild and no public exploit code.

Affected packages and fixed versions:
- surrealdb (crates.io): affected all versions; fixed in 1.5.4
- surrealdb (crates.io): affected all versions; fixed in 1.5.4
- surrealdb (crates.io): affected from 2.0.0-alpha.1; fixed in 2.0.0-alpha.6
- surrealdb (crates.io): affected from 2.0.0-alpha.1; fixed in 2.0.0-alpha.6
- surrealdb-core (crates.io): affected all versions; fixed in 1.5.1
- surrealdb-core (crates.io): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58363/ (Markdown: https://insights.sbomify.com/CVE-2024-58363/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58363
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58363
- OSV: https://osv.dev/vulnerability/CVE-2024-58363

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58363/
Summaries are generated and may contain mistakes; the official description above is the record.
